Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am fairly familiar with setting up servers, and ubuntu is generally my flavor of choice, but I just installed 12.04 desktop and I am seeing some behavior in network manager that is really puzzling. The network connection works fine if I leave it set on dhcp, but I would like a static IP address for my new web server. When I go into network manager and edit the connection for the one and only NIC I can select MANUAL from the dropdown menu but as soon as I do the Save button becomes greyed out. Even after filling out all fields for the connection it is still grey and I am unable to save the static IP connection information. Any thoughts would be greatly appreciated. I'm hoping there is just some new setting that I am unaware of....

On another note, if I stop the network manager and go edit the interfaces file (and the appropriate hosts/routes/dns files), I do get a static ip address assigned and I can contact my server from the outside, however, the server cannot find the internet. Can't ping even its own ip... I can ping the loopback interface though.

I'm really confused on this one. Hoping someone can offer some help.

share|improve this question
    
Please update your post with further information (preferably, even if censored) screenshots of the network manager UI you filled in, in order to track down what might be missing. –  user98085 Oct 30 '12 at 23:48

2 Answers 2

Do not press the Add button after entering Gateway IP address. :)

Found out this the hard way: You have to press Add the first time, to start entering the IP, but when finished - just press enter.

If you do press Add a second time, you make a new address entry and are not allowed by the GUI to save. Select the empty second line and click the Delete button in the GUI to remove it.

This is done to make it possible to enter more than one IP on the interface, but it definitivly was not obvious to me because of the minimalistic IP entry box you have to scroll in..

share|improve this answer

Did you fill in the IPv6 information? I had the same problem and was able to resolve it by setting IPv6 to 'ignore'.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.