Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

It worked normal one day, but then I turned the computer on, and suddenly only one the left speaker works. Headphones work normally.

share|improve this question
Have you verified that it is not a hardware problem? – Nanne Oct 28 '12 at 14:15
Try a livecd and figure out if it is the hardware or it has something to do with Ubuntu – Jeggy Oct 28 '12 at 14:20
Experienced the same problem and sort of solved it. Don't ask my why, but if I drag the volume bar in the system-settings to a really high volume and drag it back - it all of a sudden fixes itself. I have no clue why, but it somehow works. – Gerard Westerhof Mar 16 at 21:10

2 Answers 2


I faced the same problem, only one speaker was working. I tried everything I could get my hands on. But the solution was rather simple

I used the following command in the terminal


Then In the mixers I noticed that on everything except the master volume the green-white bars were half I increased them to full and then the bars became full and my problem was solved. It seems that only one channel is open by default.

Any way, Thanks Ubuntu "jazakAllah khair"

share|improve this answer

Maybe your speaker is not balanced properly.

  1. Open "System Settings" (via the Dock/Switcher/whatever you call it :P on the left or opening the dash, typing "System Settings" and opening the one with the Gear-and-Wrench icon)
  2. Select "Sound"
  3. Once opened, stay on the "Output" tab. Look at the first slider, one labeled "Balance".
  4. Move the slider to the middle, indicated by a line.
  5. Close the window and the System Settings window
  6. Play a video or a sound clip to see if it worked.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.