Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install ia32-libs and i tried nearly all commands to install this package but always i got an error. Here is what i've tried so far;

sudo apt-get install ia32libs

orkun@ubuntu:~$ sudo apt-get install ia32libs
[sudo] password for orkun: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
N: Ignoring file 'ferramroberto-java-quantal.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ferramroberto-java-quantal.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ferramroberto-java-quantal.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to locate package ia32libs

.

sudo apt-get install package-name:i386

orkun@ubuntu:~$ sudo apt-get install package-name:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
N: Ignoring file 'ferramroberto-java-quantal.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'ferramroberto-java-quantal.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to locate package package-name

.

Downloading this package and trying these commands;

sudo dpkg -i «package name>

orkun@ubuntu:~/İndirilenler$ sudo dpkg -i ia32-libs_20090808ubuntu36_amd64.deb
(Reading database ... 151309 files and directories currently installed.)
Preparing to replace ia32-libs 20090808ubuntu36 (using ia32-libs_20090808ubuntu36_amd64.deb) ...
Unpacking replacement ia32-libs ...
dpkg: dependency problems prevent configuration of ia32-libs:
 ia32-libs depends on ia32-libs-multiarch; however:
  Package ia32-libs-multiarch is not installed.

dpkg: error processing ia32-libs (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ia32-libs
share|improve this question

4 Answers 4

I had the same problem at first. Then I tried a few methods to solve it. The one that worked is like the following:

  1. Make sure the server you selected in the "Software Sources" is the "Main Server".
  2. Search for all packages starting with "lib32" with apt-cache search lib32.
  3. Install every package that's in the list and without any "-dbg" or "-dev" suffixes.
  4. Then you can try to install the "ia32-libs" again.

This worked for me. Hope it helps.

share|improve this answer

Complete novice here, so I suspect that this has not been overlooked, but it looks like you're missing a "-" in your first line of code.

sudo apt-get install ia32-libs

I just installed "ia32-libs" on Ubuntu 12.10 x86 as above for a JDK7u9 and NetBeans IDE 7.2.1 installation (apparently there is no 64-bit bundle).

share|improve this answer
    
This gives the same error –  Qwertie Dec 11 '13 at 0:21

Sounds like your APT doesn't have an i386 foreign architecture. I have no idea why this happens to people...

Try:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs
share|improve this answer
  1. Download and install https://packages.debian.org/wheezy/amd64/libc6-i386/download

    sudo apt-get -f install

  2. Then execute the following commands :

    sudo dpkg --add-architecture i386

    sudo apt-get update

    sudo apt-get install ia32-libs

share|improve this answer
    
Added sudo as all these commands as to be run as root. –  Benoit Jun 17 at 11:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.