Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run an old netbook with Broadcom BCM4313 wireless as a print server with Ubuntu Server 12.04. Setting up the wireless without the GUI, however, is proving problematic. I do think however I've narrowed down the problem.

I've tried both the wl driver (from bcmwl-kernel-source) as well as the (included) brcmsmac driver. With both of them, when I issue the command iwlist wlan0 scanning (eth1 for wl), I only see neighbouring networks- not my own.

I believe this might be because my networks are n-only, but my neighbouring networks are mixed mode (I suspect this because the output of iwlist wlan0 scanning shows "Bit Rates" only as high as 54 Mb/s).

Any ideas how to go about getting this thing to connect?

share|improve this question
Hi, my BCM4313 had the same problem last week. Turns out it doesn't pick up any networks on channels 12+. I lowered the network to channel 5 and now she's working. – beanaroo Oct 28 '12 at 11:20
I just saw that post actually- you're right! Many thanks. I'll go upvote your other post... – KJ Tsanaktsidis Oct 28 '12 at 11:31
Actually, the post I'm referring to isn't yours:… – KJ Tsanaktsidis Oct 28 '12 at 11:32
how did you even get any result with the wl driver for BCM4313? mine says eth1 Interface doesn't support scanning. – Ubuntuser Jan 17 '13 at 6:25
I'm not sure, it was a while ago :/ I installed it somehow from the bcmwl-kernel-source package – KJ Tsanaktsidis Jan 21 '13 at 0:26

Set your network to mix mode, should fix it up. I had the same problem.

share|improve this answer
up vote 0 down vote accepted

Disregard me, I'm stupid. The very next thing I looked up on this site claimed that it doesn't support channels > 11, and my wlan was on ch13! Changing this to 11, connection worked a charm with the wl driver, like so:

wpa_passphrase mySSID myPSK >> /etc/wpa_supplicant.conf

iwconfig eth1 essid mySSID

wpa_supplicant -D wext -i eth1 -c /etc/wpa_supplicant.conf

dhclient eth1

share|improve this answer
Glad you came right! Remember to mark the question as answered if all's well :) – beanaroo Oct 28 '12 at 11:40
Can't do it for two days... I'll try and remember! – KJ Tsanaktsidis Oct 28 '12 at 22:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.