Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have researched this problem extensively and I can't seem to find an answer. In Ubuntu 10.04 LTS, I want to connect to my VPN through the NetworkManager applet. I installed all the network manager packages, including the gnome client.

I understand I need to add the "Notification Area" to the panel, which I have done. I checked that the NetworkManager is running:

nate@nate-desktop:~$ service network-manager status
network-manager start/running, process 763

In /etc/NetworkManager/nm-system-settings.conf, I have added managed=true (don't know if this matters, but I saw it suggested on one forum):

nate@nate-desktop:~$ more /etc/NetworkManager/nm-system-settings.conf 
# This file is installed into /etc/NetworkManager, and is loaded by 
# NetworkManager by default.  To override, specify: '--config file' 
# during NM startup.  This can be done by appending to DAEMON_OPTS in 
# the file:
#
# /etc/default/NetworkManager
#

[main]
plugins=ifupdown,keyfile

[ifupdown]
#managed=false
managed=true

I restarted NetworkManager and tried rebooting, too. At this point, it looks like NetworkManager is running but it's not appearing in the NotificationArea of the panel. I don't know what else to try. Any ideas?

share|improve this question

3 Answers 3

You'll need to start the network manager applet. It's started by default, although it sounds like you've done some customisation. Here's a screenshot of my entry :

alt text

This is available through system/preferences/startup applications.

share|improve this answer

Network Manager is a separate beast from its applet for good reason: Network Manager is a daemon that persists outside of X. The applet just communicates with this daemon.

Anyway, you want to run this:

nm-applet --sm-disable

It's set to run on boot on my computer from System -> Preferences -> Startup Applications.

share|improve this answer
    
Ah, you beat me to it! –  Scaine Jan 9 '11 at 17:22

If I'm getting you right, your network-manager wasn't installed by default. It's the same case with Ubuntu minimal installs (which I've tried), and installing it later doesn't make the nm-applet appear in the notification area. I've found the answer to this problem on Ask Ubuntu itself:

sudoedit /etc/network/interfaces or sudo gedit /etc/network/interfaces

In the first command, an editor in the Terminal itself appears. Otherwise, you may use gedit as in the second command or replace it with your preferred text editor. Once the file is open, find your network interfaces, like eth0 or something and add # in front of the line it's mentioned. Reboot and the network manager's icon should appear normally in the notification area.

share|improve this answer
    
For a graphical text editor like Gedit, gksu (or gksudo) should be used instead of straight sudo, to avoid breaking things. –  Eliah Kagan Apr 2 '13 at 16:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.