Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
[.../~]$ mount
/dev/sda4 on / type ext4 (rw,commit=60,commit=0)



[.../~]$ cat /etc/fstab
# UNCONFIGURED FSTAB FOR BASE SYSTEM
UUID=70739c04-fcb6-4747-803c-824f9c894f41  /  ext4  defaults,commit=60  0 1

What can I do about it? It seems strange. I want to be able to set any commit time I want

Edit: added /proc/mounts contents

[.../~]$ cat /proc/mounts 
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
none /dev devtmpfs rw,relatime,size=886332k,nr_inodes=221583,mode=755 0 0
none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
/dev/disk/by-uuid/70739c04-fcb6-4747-803c-824f9c894f41 / ext4 rw,relatime,barrier=1,data=ordered 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
/dev/sda3 /media/megahard fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0
cgroup /dev/cgroup/cpu cgroup rw,relatime,cpu,release_agent=/usr/local/sbin/cgroup_clean 0 0
gvfs-fuse-daemon /home/va1en0k/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0

Another edit:

[.../~]$ cat /etc/mtab
/dev/sda4 / ext4 rw,commit=60,commit=0 0 0
none /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
/dev/sda3 /media/megahard fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0
cgroup /dev/cgroup/cpu cgroup rw,cpu 0 0
gvfs-fuse-daemon /home/va1en0k/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=va1en0k 0 0
share|improve this question
    
I wonder how the mount command gets the mount options? What's in /etc/mtab? I wonder if that latter file is somehow out of date. –  poolie Jan 11 '11 at 15:16
    
added this file –  valya Jan 12 '11 at 0:31
    
I vaguely remember that you have to do something special to change the root fs mount options. But I can't remember at all what it was. –  Ryan Thompson Jan 12 '11 at 3:04
add comment

4 Answers

You can control the root mount options by using the rootflags option. To try this once, press 'e' at the grub menu and add it to the kernel line. If you're happy with the result and want to make it permanent, add it to /etc/default/grub and run update-grub.

share|improve this answer
add comment

pm-utils is overriding your custom settings. See /usr/lib/pm-utils/power.d/journal-commit.

To make the OS stop assuming it's smarter than you about commit settings, create an empty, non-executable file with the same name in /etc/pm/power.d (i.e. touch /etc/pm/power.d/journal-commit).

share|improve this answer
add comment

That looks like a bug: commit can't be both 0 and 60. What does cat /proc/mounts say the options are? If that is correct, then /etc/mtab got messed up somehow, which is what mount reports.

share|improve this answer
    
I edited my question, thank you –  valya Jan 11 '11 at 0:31
    
Yep, bug. /etc/mtab is screwed up. –  psusi Jan 15 '11 at 1:22
add comment

I think the mount options for the root filesystem are controlled by the fstab that was in use in the initramfs.

sudo update-initramfs

may fix it.

share|improve this answer
    
I've ran ` sudo update-initramfs -u` (because it won't run without any options), was I right? –  valya Jan 11 '11 at 0:32
    
(it changed nothing) –  valya Jan 11 '11 at 0:43
2  
There is no fstab in the initramfs. It mounts the root using the flags from the rootflags kernel option initially, but I'm pretty sure that mountall should remount the root with the options specified in fstab. –  psusi Jan 15 '11 at 1:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.