Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to conduct a SMART test on my drive but it was disabled. So, i used

sudo smartctl -s on /dev/sda 

but the result was

smartctl 5.41 2011-06-09 r3365 [i686-linux-3.2.0-26-generic] (local build)
Copyright (C) 2002-11 by Bruce Allen,

Error SMART Enable failed: scsi error aborted command
Smartctl: SMART Enable Failed.

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

How to overcome this problem?

share|improve this question

Check inside your BIOS if the SMART functionality is enable. Depending on your hardware it's on different menus but generally you can find it where your hard drives are defined or in advanced features.

If this is not enough you can afterwards enable it with hdparm.

Check if you can use it with :

sudo hdparm -I /dev/sda

/dev/sda being the hard drive you want to check

this command will show you what's enabled or not

To enable SMART if not enabled you can do this command :

sudo smartctl --smart=on /dev/sda

When you ends with error it may means two things :

  • You simply can't do it
  • you need to specify the BUS used

For the second part you must give use more details (the hdparm -I output for instance, the hard drive model, the computer or motherboard model, etc etc)

The easiest and 100% sure working method is by changing the value inside the BIOS.

Best regards.

share|improve this answer
The second command gives me -s: bad/missing powerup-in-standby value (0..1) and changing it to 1 gives a warning. – Abhay Rana Oct 28 '12 at 10:42
Did you went first inside your BIOS ? What is the brand/model of your computer or motherboard ? – Antoine Rodriguez Oct 28 '12 at 10:52
I've made a slight error in my answer. correcting it. – Antoine Rodriguez Oct 28 '12 at 10:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.