Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.10 alongside Windows 7. I split my partition into two because disk reader during the installation didn't recognize Windows 7 as being installed on the computer. It installed correctly and I restarted only to find out it wasn't recognized in Grub also and booted straight to Ubuntu.

I read this post and thought of using boot-repair would be fine but I gain this error:

gpt detected. 
Please create bios-boot partition (>1MB, unformed filesystem, bios_grub flag). 
This can be performed via tools such as Gparted. 
Then try again.

I've no idea what it means or what to do next. Suggestions would be appreciated and I have lost my Windows installation disk and I really don't want to have to go looking for it.

EDIT: This is what boot-repair came back with. http://paste.ubuntu.com/1326230/

share|improve this question
add comment

2 Answers 2

Well the error says it all, you have GPT standard so you must also add a BIOS-Boot or an EFI partition depending on the boot mode of your BIOS.

You can read about here..https://help.ubuntu.com/community/DiskSpace

share|improve this answer
1  
Ok, that fixed the issue with boot-repair not working. I ran the program, however, it still does not detect Windows 7 on the hard drive. –  rowanquigley Oct 29 '12 at 12:19
    
Well, if you had the windows 7 installation disk it would have been easier I suppose... in that case you had to repair your startup, and if that didn't work, you had to go to cmd via repair and type the following: 1. bootrec /fixBoot 2. bootrec /rebuildBCD Hope it helps. –  ravisvi Oct 31 '12 at 15:35
add comment

Hey try going to the terminal via ubuntu and type

sudo update-grub

And if that too doesn't recognise windows then go to terminal and type:

sudo apt-get install os-prober
sudo update-grub
grep menuentry /boot/grub/grub.cfg

If that too doesn't work, see if this might be of any help, https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1007923 It's for 12.04 though.

Let me know if anything worked.

share|improve this answer
    
Those commands didn't really show me or do anything. The link however worked to an extent. I however, just need to find my disk and repair the bootmgr. I don't know how but I'm sure I'll be able to somewhere. Suggestions would be great, we're halfway there. –  rowanquigley Nov 2 '12 at 11:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.