Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to re-install Oracle JDK 7 32 bit to 64 bit Ubuntu (previously 64 bit JDK was installed). JDK is currently present at /usr/lib/jvm/jdk1.7.0. I invoke

sudo update-alternatives --remove "java" "/usr/lib/jvm/jdk1.7.0/bin/java"
sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk1.7.0/bin/java" 1

And then:

/usr/lib/jvm/jdk1.7.0/bin$ java
bash: /usr/bin/java: No such file or directory

Why java can't be invoked?

share|improve this question
up vote 26 down vote accepted

This message is shown because some 32 bit libraries are absent in Ubuntu 64 bit. Run:

apt-get install libc6-i386

See Java is installed, in listing, but execution produces “./java: No such file or directory” for more details

share|improve this answer
are these library jre-specific or are these libraries required for other packages too? – ShuklaSannidhya Apr 3 '13 at 4:23

what u are doing is trying to execute binary file without telling its path,
for executing java binary try "./java" in bin folder else include its whole path and for installation you may try this :-

share|improve this answer
When in bin folder ./java outputs "No such file or directory" – Andrei Botalov Oct 28 '12 at 9:11
list all files in that dir and see if there is such file or not if its not then i think u have to re-install it – r4jiv007 Oct 28 '12 at 9:13
There is "java" file there. It's in light green – Andrei Botalov Oct 28 '12 at 9:18
try to run the commands mentioned in the link i provided, see whether that helps !! – r4jiv007 Oct 28 '12 at 9:22
I've already runned all those commands with zero success. I have the same output "bash: /usr/bin/java: No such file or directory" – Andrei Botalov Oct 28 '12 at 9:36

I was helping a friend with their RiotBoard running Linaro-Ubuntu to set it up as a minecraft server. We got the same error. The problem I found was that Java was referencing /lib/ which does not exist on the system. When you look at /lib the only load file is /lib/ so I just soft link them and it works. Below is how I worked it out and what I did to fix it.

root@linaro-ubuntu-desktop:/opt/java/jdk1.8.0_06/bin# java
-su: /usr/bin/java: No such file or directory

root@linaro-ubuntu-desktop:/opt/java/jdk1.8.0_06/bin# strings java


root@linaro-ubuntu-desktop:/opt/java/jdk1.8.0_06/bin# ls /lib/ld*


root@linaro-ubuntu-desktop:/opt/java/jdk1.8.0_06/bin# ln -s /lib/ /lib/

root@linaro-ubuntu-desktop:/opt/java/jdk1.8.0_06/bin# ls /lib/ld*

/lib/  /lib/

root@linaro-ubuntu-desktop:/opt/java/jdk1.8.0_06/bin# java -version

java version "1.8.0_06"

Java(TM) SE Runtime Environment (build 1.8.0_06-b23)
Java HotSpot(TM) Client VM (build 25.6-b23, mixed mode)
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.