Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In /var/log/suspend.log, all is a success or not applicable, except these lines:

Having NetworkManager put all interaces to sleep...Failed.

Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory

Having NetworkManager wake interfaces back up...Failed.

I'm not sure that they are relevant, but I'm stymied.

I tried adjusting the brightness via keyboard, and also tried opening a terminal and commanding a shutdown, but neither worked, so it appears to not load properly at all, though the screen backlight is powered and the system is running.

This is an HP Pavillion Dv7 notebook.

share|improve this question

3 Answers 3

up vote 2 down vote accepted
+50

I have a suggestion which might be worth trying,

If your system has AMD/ATI graphic card and you are using Proprietary drivers then try disabling them and using the default/ Xorg Radeon drivers, one that Ubuntu selects.

(This may or may not work.. Its Only a guess..)

share|improve this answer

I had a similar issue, and it's pretty easy to solve. I'm assuming that this is happening when you open the lid, and it just doesn't seem to wake. What I did was go into system settings, open Power, and under both columns set "When lid is closed" to "Do nothing". I also have it set under Brightness and Lock to not lock the screen. I hope that this helps. Good luck.

share|improve this answer
    
Well the lid isn't necessarily closed when I put it to sleep. That's not really a solution such as a workaround. I'd like to be able to put my laptop to sleep. –  Alex Nye Oct 31 '12 at 2:58
    
Yeah, I haven't figured out how to fix that yet. In the meantime, this has worked relatively well, so I would recommend using it until you find a better solution. –  Evan Pak Oct 31 '12 at 13:43

You can fix it by updating BIOS

  1. Reinstall Windows
  2. Download and install bios-update from HP's website

Now it should suspend perfectly!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.