Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting this error installing IDLE on 12.10:

Software can't be installed or removed because the authentication service is not available.
(org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.95'}): 

I can't install anything, even games. They all come up with the same error message.

Is there something I am missing? Please suggest.

share|improve this question

A temporary workaround to this is:

sudo software-center
share|improve this answer

Try this:

sudo apt-get update
sudo apt-get install idle3

Also, it is possible your package manager is being blocked by another process, like an update in the background, or another install that did not complete. You can try rebooting, and then issuing the following, which will finish any incomplete installations:

sudo dpkg --configure -a
share|improve this answer
first solution worked for me! thanx – Paschalis Nov 26 '12 at 10:17
error returned... tried second solution also, but problem persists... it just dont ask me for my credentials, and that message appears... – Paschalis Nov 26 '12 at 10:47
not worked for me on ubuntu 14.04 – GGsalas Apr 26 '14 at 16:27
Had same problem, reconfiguring didn't fix it. Used sudo dpkg --purge packageName to clear out the offending entries. – TraxusIV Aug 18 '15 at 22:29

There were some updates pending for my ubuntu installation. I updated my ubuntu and everything started working fine for me afterwards.

thanks for all your help

With Regards Gagan Janjua

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.