Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been running Ubuntu 12.04 on my HP Pavilion G6 notebook for 4 months now. There were no issues at all. Today, I tried to connect using the wifi, it doesn't turn on but bluetooth which is also integrated with the same key (F12) turned on and it is working fine. There is light indicator(red when wifi disabled) on that F12 switch, it should become white when enabling the wifi but today it remained red though bluetooth got enabled.

I tried following solution but it does not work.

Try to re-install the drivers by using:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install bcmwl-kernel-source

I recently made a few changes, they are:

  • Installed Matlab.
  • Updated kernel to 3.6.3 but rolled back to linux kernel 3.2 as my notebook failed to boot after upgrading the kernel.
  • Installed 0AD game.

System info:

Product Name: HP g6-1209ax
Product Number: A3V45PA
Microprocessor: 2.3 GHz/1.4 GHz AMD Quad-Core A6-3400M
Microprocessor Cache: 4 MB L2 cache
Memory: 4 GB 1333 MHz DDR3
Max Memory: Upgradeable to 8 GB DDR3
Video Graphics: AMD Radeon HD 6470M (1 GB DDR3 dedicated)
Display: 15.6" High-Definition LED HP Brightview Display (1366 x 768)
Hard Drive: 500 GB SATA (5400 rpm)
Multimedia Drive: SuperMulti DVD±R/RW with Double Layer Support
Network Card: Integrated 10/100 BASE-T Ethernet LAN
Wireless Connectivity: Bluetooth 802.11 b/g/n
Sound: Altec Lansing speakers SRS Premium Sound
Keyboard: Notebook keyboard with home roll keys
Trackpad: TouchPad supporting Multi-Touch gestures with On/Off button
PC Card Slots: Multi-Format Digital Media Card Reader for Secure Digital cards, 

Multimedia cards and External Ports:

3 USB 2.0

1 VGA

1 RJ-45 / Ethernet

1 Headphone out (Stereo)

1 microphone-in

Dimensions 37.4 x 24.5 x 3.63 cm

Weight Starting at 2.3 kg

Power 90W AC Power Adapter

6-cell Lithium-Ion (Li-Ion)

Any help or suggestions will be greatly appreciated!

share|improve this question

2 Answers 2

you can try another distribution to see if you can connect to a hotspot. if you can, there's something wrong with your ubuntu, drivers are a deep part of the system, so may i suggest that you reinstall the whole system. if you can't, there's something wrong with you laptop, and you may need to take the machine to the service center.

share|improve this answer

I was had the same problem but I was fixed it by using backported broadcom-sta-dkms

To install it:

$ sudo add-apt-repository ppa:poliva/pof
$ sudo apt-get update
$ sudo apt-get install broadcom-sta-dkms

And one more warning. Mostly driver built for Ubuntu 12.04 LTS aren't work with mainline kernel or 12.10 kernel

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.