Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems that no questions in this site is the same with mine.

The Eclipse splash window shows up but no progress bar at the bottom of it. I wait a long time but it just hang up there. I've tried to download the Eclipse tarball from Eclipse official website, it doesn't work either.

How can I debug this issue? Thanks.

Start VM: -Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-Djava.class.path=/home/ftao/downloads/software/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
-os linux
-ws gtk
-arch x86
-showsplash /home/ftao/downloads/software/eclipse//plugins/org.eclipse.platform_4.2.1.v201209141800/splash.bmp
-launcher /home/ftao/downloads/software/eclipse/eclipse
-name Eclipse
--launcher.library /home/ftao/downloads/software/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20120522-1813/eclipse_1502.so
-startup /home/ftao/downloads/software/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.overrideVmargs
-product org.eclipse.epp.package.cpp.product
-debug
-vm /usr/lib/jvm/java-6-openjdk-i386/jre/bin/../lib/i386/client/libjvm.so
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-Djava.class.path=/home/ftao/downloads/software/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar 
Install location:
    file:/home/ftao/downloads/software/eclipse/
Configuration file:
    file:/home/ftao/downloads/software/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/ftao/downloads/software/eclipse/configuration/
Framework located:
    file:/home/ftao/downloads/software/eclipse/plugins/org.eclipse.osgi_3.8.1.v20120830-144521.jar
Framework classpath:
    file:/home/ftao/downloads/software/eclipse/plugins/org.eclipse.osgi_3.8.1.v20120830-144521.jar
Splash location:
    /home/ftao/downloads/software/eclipse//plugins/org.eclipse.platform_4.2.1.v201209141800/splash.bmp
Debug options:
    file:/home/ftao/downloads/software/eclipse/.options not found
Time to load bundles: 4
Starting application: 1679
share|improve this question
    
Have you tried starting Eclipse from the terminal? –  daslinkard Oct 28 '12 at 4:58
    
@daslinkard, yes, that's what I did. Nothing visible from stdout/stderr of the terminal. So I feel hard to figure out what's going wrong with it. –  solotim Oct 28 '12 at 5:01
add comment

2 Answers 2

The first step I always take is to start the program in a Terminal window and read the messages that crop up there. If you don't see anything other than Segmentation fault or something equally terse then see if the program has a debug or verbose flag; the man page often has these flags listed.

For Eclipse, I believe the relevant option is -debug. Please double check this though; I'm not 100% sure. Post any output you get so we can help!

share|improve this answer
    
Thanks. With "-debug" option, I can get more info from the terminal. Could you please take a look at it? –  solotim Oct 28 '12 at 5:13
    
From what I can see in the output, there is no error explicitly printed. It does looks like it just sits there! Check your CPU and other resource usage (like RAM and HDD access). Are any of these pegged? If so, be patient. –  thirtythreeforty Oct 28 '12 at 5:27
    
No abnormal hardware resource usage changes. :( –  solotim Oct 28 '12 at 9:01
add comment

Have you tried -clean option ?

I met the same trouble today, recovered.

share|improve this answer
1  
thanks, but it doesn't work for me. Still hang~ :\ –  solotim Oct 28 '12 at 8:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.