Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to enable 3D in Ubuntu 12.04.

I recently tried to install ubuntu on a new computer. When the installation was complete and I rebooted the machine, I could only see a blank screen.

After some searching, I followed this tutorial which instructed me to boot with "nomodeset" enabled. I choose this on the USB I was installing ubuntu 12.04 from.

Fortunately, the ubuntu installation on the new computer was successful. When I tried to change the size of the unity launcher icons, I did not see that option (as I see on my other computer running ubuntu 12.04).

I tried installing MyUnity and it told me that the computer I had just installed 12.04 to was running in 2D.

To my knowledge. all the software is up to date (as I ran the Software Updater). In addition, when I look for Additional Drivers, I see a message that says "No proprietary drivers are in use on this system".

When I look under System Details > Graphics, I see the Driver as "VESA:Intel Sandybridge/Ivybridge Graphics.

When I hold the shift key on when my machine boots up, and type "e" on the Grub menu, I see the following towards the end, "nomodeset quiet splash $vt_handoff".

Does this have anything to do with the plain 2D ubuntu 12.04 experience? Again, what I'd like to do now is get the 3D experience on my new machine running 12.04.

Please let me know if you need more information.

share|improve this question

2 Answers 2

One more update. I went through the other kernel boot options in the same post, however, this time, I choose acpi=off (when I reinstalled ubuntu 12.04), and this time Unity 3D successfully launched.

share|improve this answer

I tried updating from 12.04 to 12.10 and it turns out that my hardware does not have 3D support for running the unity environment.

Here is the link I was directed to around the Unity 3D issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.