Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unable to mount hard disk and got this message:

Unable to mount 158 GB Filesystem
Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try dmesg | tail or so

From the terminal, I tried syslog - try:

No command 'syslog' found, did you mean:
Command 'dsyslog' from package 'dsyslog' (universe)
Command 'syslogd' from package 'sysklogd' (universe)
Command 'syslogd' from package 'inetutils-syslogd' (universe)
Command 'syslogd' from package 'busybox-syslogd' (universe)
syslog: command not found

Also tried dmesg | tail:

[ 971.390588] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 12 62 30 80 00 00 40 00
[ 971.390600] end_request: I/O error, dev sda, sector 308424832
[ 971.390605] Read-error on swap-device (8:0:308424840)
[ 971.390608] Read-error on swap-device (8:0:308424848)
[ 971.390617] Read-error on swap-device (8:0:308424856)
[ 971.390620] Read-error on swap-device (8:0:308424864)
[ 971.390623] Read-error on swap-device (8:0:308424872)
[ 971.390626] Read-error on swap-device (8:0:308424880)
[ 971.390629] Read-error on swap-device (8:0:308424888)
[ 971.390632] Read-error on swap-device (8:0:308424896)

It was fine before I tried to re-install 12.04 from the live CD (which failed due to the disk problem).

share|improve this question
So... what was the command you were originally trying to mount with? It sounds like you tried to mount it as the wrong filesystem (e.g., NTFS instead of EXT4,) and that you also specified an invalid flag (e.g., -tw instead of -rw.) – JamesTheAwesomeDude Oct 28 '12 at 4:01
possible duplicate of how to interpret these errors from syslog – Eliah Kagan Sep 9 '14 at 21:59

Boot off the LiveCD and try:

sudo mount errors=remount-ro /dev/sda1 /mnt

If this manages to mount the drive in read only mode, you should back up any important data that you may have which should now be accessible at /mnt/home/your_user_name/

If it complains about not knowing what the filesystem type is, try

sudo mount -t ext2 errors=remount-ro /dev/sda1 /mnt

It seems the device might be failing if it's not completely dead. You won't know for sure until you back it up and try to reformat from scratch and test it. Anything that says "read error" is pretty bad news and I don't think it's a good candidate for recovery as it is now.

share|improve this answer

Boot machine using live CD, open terminal and unmount other partitions excluding the 158 GB partition and type:

sudo  fsck /dev/sdaX

where X is your 158 GB partition.

share|improve this answer
The read errors are a concern. I don't think I'd try to write to this drive until an attempt at read-only backup has been done. – fabricator4 Oct 28 '12 at 4:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.