Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from ubuntu 12.04 to ubuntu 12.10. After this it is not updating . THe software updater gives the following error :


    W:Failed to fetch http://archive.canonical.com/ubuntu/dists/precise/Release.gpg  Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://extras.ubuntu.com/ubuntu/dists/quantal/Release.gpg  Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/Release.gpg  Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-updates/Release.gpg  Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-backports/Release.gpg Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-security/Release.gpg Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-proposed/Release.gpg Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/restricted/source/Sources Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/main/source/Sources  Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/multiverse/source/Sources Unable to connect to 10.4.42.15:8080:
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/universe/source/Sources Unable to connect to 10.4.42.15:8080:
      :
    W:Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-proposed/universe/i18n/Translation-en Unable to connect to 10.4.42.15:8080:
    E:Some index files failed to download. They have been ignored, or old ones used instead.

Along with this I am not able to install any thing from software center, it just asks to use this source and after that it just keeps on querying software sources and nothing happens after that

The contents of /etc/apt/sources.list are:


#deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Release i386 (20120423)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ quantal main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ quantal restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ quantal-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ quantal-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ quantal universe
deb http://us.archive.ubuntu.com/ubuntu/ quantal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ quantal multiverse
deb http://us.archive.ubuntu.com/ubuntu/ quantal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse #Added by software-properties

deb http://us.archive.ubuntu.com/ubuntu/ quantal-security main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ quantal-security restricted main multiverse universe #Added by software-properties
deb http://us.archive.ubuntu.com/ubuntu/ quantal-security universe
deb http://us.archive.ubuntu.com/ubuntu/ quantal-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu quantal main
deb-src http://extras.ubuntu.com/ubuntu quantal main
# deb http://download.learnfree.eu/repository/skss / #SKSS
# deb-src http://download.learnfree.eu/repository/skss / #SKSS
deb http://us.archive.ubuntu.com/ubuntu/ quantal-proposed restricted main multiverse universe
deb-src http://us.archive.ubuntu.com/ubuntu/ quantal-proposed restricted main multiverse universe #Added by software-properties

share|improve this question
    
You can try this out in the terminal sudo apt-get update -f and then sudo apt-get update. Hope this works. –  Max Tither Oct 28 '12 at 2:51
    
after sudo apt-get update -f i am getting the same error –  gunjan parashar Oct 28 '12 at 3:30
    
You may not be connecting to the internet, try this: askubuntu.com/questions/135932/… –  Max Tither Oct 28 '12 at 4:05
    
Did you recently upgrade to 12.10 and it worked previously? Also what happens when you reboot your system and try to update? –  daslinkard Oct 28 '12 at 5:04
3  
@gunjanparashar - please add to your question what 10.4.42.15:8080 actually is - looks like you have a proxy - how have you set this up? Are you using a proxy like this Q&A? askubuntu.com/questions/23666/apt-get-does-not-work-with-proxy/… –  fossfreedom Oct 30 '12 at 23:29
show 1 more comment

7 Answers

up vote 1 down vote accepted
+50

I've had this problem myself with Ubuntu 12.10. Be careful what you do to try to fix this - I ended up re-installing 12.04 to fix my machine. With that said, there is a bug report on Launchpad (sory, can't find it) that explains how Ubuntu 12.10 enables a DNS feature dnsdmasq by default, which messes up a lot of systems. This article explains how to disable dnsdmaq. http://www.ubuntugeek.com/how-to-disable-dnsmasq-in-ubuntu-12-04precise.html

Verbatim from the article: "

You need to edit /etc/NetworkManager/NetworkManager.conf file

$ gksudo gedit /etc/NetworkManager/NetworkManager.conf

and comment out the following line from

dns=dnsmasq

to

#dns=dnsmasq

Save and exit the file

Now you need to network-manager using the following command

$sudo restart network-manager

"

Hope that helps.

share|improve this answer
    
thanks bro for helping actually it was a problem with the proxy , thanks a lot –  gunjan parashar Oct 31 '12 at 20:48
    
@gunjanparashar don't forget to mark an answer as "Accepted" if the answer helped. –  Thomas W. Nov 1 '12 at 15:24
add comment

Sounds like an internet issue. (Unable to connect to X.X.X.X:XXXX:) Try disabling your Firewall, and getting out from behind any proxies you may be using. If that doesn't fix it, I'd recommend changing your DNS. Your ISP may be giving you a lame DNS server (or maybe you manually set up a lame one. ;)

Anyway, to do this, just set your DNS servers to 208.67.222.222, 208.67.220.220 (that's OpenDNS; there are others. Pick one that you like, but, most importantly, pick one that works.) If you don't know how to do this, detailed instructions can be found here.

share|improve this answer
    
i am using opendns ony –  gunjan parashar Oct 28 '12 at 18:55
    
So... you're already using OpenDns? Try a different one, then. Also, do you normally have internet trouble? (e.g., frequent connection errors when surfing the web, Wi-Fi is unstable, etc. –  JamesTheAwesomeDude Nov 5 '12 at 4:20
    
Hey... another good DNS provider is Google's DNS - they don't screw up nxdomain like OpenDNS does. Primary server is 8.8.8.8 secondary 8.8.4.4. –  JamesTheAwesomeDude Apr 22 '13 at 21:50
add comment

I finally found the solution to the problem of ubuntu 12.10 not getting updated. There actually was some problem with the proxy, so what I did was as follows:

I ran gksudo gedit /etc/apt/apt.conf to edit the apt.conf file, then

added the line below in the apt.conf file:

Acquire::http::Proxy "false";

now everything is going as smoothly as it was.

share|improve this answer
    
thanks dear for the help really peoples who r giving the answers are making open source open source in real sense –  gunjan parashar Oct 31 '12 at 20:49
add comment

i SOLVE IT

when i run

vi /etc/apt/apt.conf

i found in this file strange config with this ip: 41.191.27.92

Acquire::http::Proxy "ΗττΡ://41.191.27.92:8080";

delete this line and add:

Acquire::http::Proxy "false";

after:

sudo rm -rf /var/lib/apt/lists/* -vf 

sudo apt-get update

and all work perfect!

why i found this ip in my this configuration file???

share|improve this answer
add comment

In the Others tab of the Software Sources configuration, try unchecking the following

1. Canonical Partners (Source Code)
2. Independent (Source Code)
3. Independent

If it works, then great. But remember to periodically enable these repositories to check if they have fixed the issue.

share|improve this answer
add comment

Also, you may want to check the routing tables if you have been playing with it at all.

route -n

Be sure the net 0.0.0.0 is configured for the correct gateway. e.g.

root@home:/# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
share|improve this answer
add comment

It's a known bug - just add using your preferred editor the following to your /etc/network/interfaces at the end of eth0 declaration (or whatever interface you use to connect to the network):

auto eth0
iface eth0 inet static
...
dns-nameservers 8.8.8.8 8.8.4.4
dns-search domain.local

Then restart apache2 with sudo apache2 restart.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.