Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For a while since I've switched to Ubuntu from Windows, I've been wondering about this. In windows, you can select an item in a listbox, hold Ctrl+Shift, then select another item, and all the items between the two that you selected will also be selected (see the picture below). My problem is, in some cases I have a few hundred items to select out of thousands, and the only way to select them is to individually select each of them while holding Ctrl. Is there a way to enable this ability in Ubuntu (even if it's just for GTK programs)?

http://i.stack.imgur.com/RrvRy.png

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

It does indeed work this way, except you don't click on the item that is already selected, you have to click on the last item that is not selected.

Interestingly, "last item" depends on whether selected the top set first or the bottom set. If you selected the bottom item first the the "last item" is actually the upper one of the group in between. It's kind of intuitive, but would be odd if the system you used previously works in a slightly different way.

Recap:

It already does what you want. Select and item at the top of the list. Scroll down. Select and item at the bottom of the list while holding Ctrl. Now hold CtrlShift and click on the last unselected item and all the items in between will be selected.

Of course, you could also have just selected one item at the top, then CtrlShift clicked on the last item to achieve the same result. It appears to work exactly how you want it to.

share|improve this answer
    
I'm sorry, but I have no idea how that works as you described it. Could you re-explain or illustrate this for me? Thanks for your help. –  Spice Oct 28 '12 at 1:41
    
Strange, it doesn't seem to work. I've tried it in FileZilla and Deluge, and neither of them seem to work, yet it works just fine in Nautilus when in list view. –  Spice Oct 28 '12 at 2:20
    
Odd, it must be application specific. You could file it as bug again FileZilla a Deluge, if they don't exist already. –  fabricator4 Oct 28 '12 at 2:37
    
I'll do just that. Thanks for all your help. –  Spice Oct 28 '12 at 3:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.