Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when I start my computer, the system starts in GRUB. If I run these commands (as follows):

set root=(hd0,1)
linux /vmlinuz root=/dev/sda1
initrd /initrd.img
boot

I can start Ubuntu, but then when I go to restart, it loads to GRUB and I have to keep typing the commands in grub to boot.

How can I fix this so when I turn on my computer Ubuntu will run without having to keep typing in these commands every time?

share|improve this question

1 Answer 1

You have to fix grub-boot loader properly, so you don't have to type command every time you boot system.

Try the boot repair CD or boot repair tool. Boot with this CD and let repair the program your grub. https://help.ubuntu.com/community/Boot-Repair

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.