Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

sudo fdisk -l lists the drive, however, I cannot find it in the file explorer.

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d871e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   486322175   243160064   83  Linux
/dev/sda2       486324222   488396799     1036289    5  Extended
/dev/sda5       486324224   488396799     1036288   82  Linux swap / Solaris

Disk /dev/sdb: 8195 MB, 8195480064 bytes
253 heads, 62 sectors/track, 1020 cylinders, total 16006797 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00027ae4

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          62    15999719 M    7999829    c  W95 FAT32 (LBA)

Manually mounting it produces this error message

:~$ sudo mount -t vfat /dev/sdb1 /media/external -ouiduid=1000,gid=1000,utf8,dmask=027,fmask=137        
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Is the usb toast?

UPDATE: Thank you to everyone who has responded thus far. It is a Sandisk Cruzer and the solution proposed by fabricator4 worked.

share|improve this question
    
You try ext4? And is this one of those Sandisk Cruzer usb drives? –  Dominic Jordan Hasford Oct 27 '12 at 22:39
    
If the below posted answer worked, please consider accepting it by clicking on the check mark button to the left of the post. Thank you. –  Peachy Nov 1 '12 at 17:42
add comment

1 Answer 1

No, it's not toast. Startup disk creator is very particular about the partition table, and the partition table written by the manufacturers is often inconsistent with Linux. Another symptom is that Disk Utility and Gparted are not able to delete the partition table.

You can repair the device by erasing the partition table with dd:

dd if=/dev/zero of=/dev/sdX bs=512 count=1

Change sdX to the correct device which in your example above will be sdb. Do not get it wrong because the target device will be made completely blank in the blink of an eye. There will be nothing visible on the device after you run this command.

You can then create a new partition table with disk utility or Gparted and create a FAT partition that boot disk creator (and linux utilities in general) will be happy with.

A possible explanation for the inconsistent treatment of partition tables can be found in the Linux cfdisk manual page (cfdisk is a text based utility for manipulating disk partition tables):

DOS 6.x WARNING

   The DOS 6.x FORMAT command looks for some information in the first sec‐
   tor of the data area of the partition, and treats this  information  as
   more  reliable than the information in the partition table.  DOS FORMAT
   expects DOS FDISK to clear the first 512 bytes of the data  area  of  a
   partition  whenever a size change occurs.  DOS FORMAT will look at this
   extra information even if the /U flag is given -- we  consider  this  a
   bug in DOS FORMAT and DOS FDISK.

Partitioning and formatting tools that may be based on DOS versions or use the same logic for making partitions that are used by the OEMs may therefore be setting Linux users up for this problem. The main USB sticks I've had problems with are the good branded ones (eg. Verbatim) that include so-called backup or synchronisation software for Windows based machines.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.