Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 12.04 and also installed Google Earth. After opening Google earth instead of the maps only appears a black screen (I can see the menus with a lot of options in grey). After waiting a few minutes, I see an error saying that google earth was unable to connect to the image server.

I used to have in the same computer Google Earth on ubuntu 10.10 without any problems. Internet works fine, even I can use the internal browser of google earth. I tried disabling ipv6, deleting ~/.config/google and everything I found in google, but it didn't work. Can anybody help me?

share|improve this question

2 Answers 2

I also show the following shared library dependencies missing after following Google's installation procedures on Ubuntu 12.04

test@localhost:~$ ldd /opt/google/earth/free/googleearth-bin |grep "not found"
libgoogleearth_free.so => not found
libglobalnew.so => not found

System Details:

uname -a
Linux test 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

It appears that both 'missing' dependencies are actually installed.

test@localhost:~$ locate libgoogleearth_free.so
/opt/google/earth/free/libgoogleearth_free.so

test@localhost:~$ locate libglobalnew.so
/opt/google/earth/free/libglobalnew.so

This apparent library dependency can be satisfied in Ubuntu 12.04 executing the following:

test@localhost:~$ sudo echo "/opt/google/earth/free/" >> /etc/ld.so.conf.d/google-earth.conf && ldconfig

Unfortunately, Google Earth still exhibits the same symptoms when launched. (i.e. Black rendering area and seemingly unable to connect to the server with grayed menu options.)

It looks like this thread also discusses the issue:

Their solution of uninstalling the 64-bit version and subsequently installing the 32-bit version did not work.

share|improve this answer
    
I have solved the problem of the missing libraries, but it still doesn't work, black screen and no connection to the server. My system is 32 bit (Linux bacterio-System-Product-Name 3.2.0-32-generic-pae #51-Ubuntu SMP Wed Sep 26 21:54:23 UTC 2012 i686 i686 i386 GNU/Linux) –  rafmunoz Nov 1 '12 at 1:08
1  
The above way of adding the libraries causes errors when runing other programs like skype or marble regarding Qt libraries. I have solve this problem making links in /usr/lib/i386-linux-gnu. I stil have the problem of the black screen and unable to connect server. –  rafmunoz Nov 5 '12 at 22:08

Is the whole screen a black screen or just the right window where the 3d view of the earth appears?

How did you install Google Earth? Did you download the original package and install the libgl package with wget http://librarian.launchpad.net/7037027/libGL.so.1 -O libGL.so.1?

If you are using 10.04, you can install Google Earth from the mediabuntu package, maybe this works. Otherwise, if you use 10.10, you can use this guide. This worked for me in 10.10 after I got crashes and black screens while using the original package. Using the original package was a mistake, because the original package never worked for me.

share|improve this answer
    
The black screen is only in the 3d view where the earth appears. I use 12.04. I have installed "googleearth 6.0.3.2197+0.7.0-1". –  rafmunoz Oct 27 '12 at 22:22
    
How did you install it? –  user100349 Oct 27 '12 at 22:51
    
I reinstalled GE folowing this instructions: tatobenavidez.blogspot.com.es/2012/06/… –  rafmunoz Oct 28 '12 at 0:37
    
Does it work? I check the link out –  user100349 Oct 28 '12 at 19:21
    
It didn't work. Just the same problem –  rafmunoz Oct 29 '12 at 20:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.