Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A pop up keeping appearing in Ubuntu (running 12.10), asking for the password to my gmail account. The icon has a silver shield, and it is labeled Access Prompt.

The actual window has an image of keys on a keyring, says Authentication request in bold, and Please enter your password for the account, [gmail address] It keeps saying my passwords are incorrect... I'm not even sure which account it's talking about. What is going on?

share|improve this question
1  
Same here. I'm also running 12.10. Seems to be related to the gcr package as shown in the bug report here –  jairo Nov 3 '12 at 17:08
    
Try advice # 4 from 10 Things To Do After Installing Ubuntu 12.10 in a reverse manner, i.e. remove your online account/s. –  user104382 Nov 4 '12 at 7:40
add comment

6 Answers 6

up vote 5 down vote accepted

Evgeni Leshtanski's answer clued me in to what was really happening. The question isn't, "How do I tell some random prompt what my password is?" but rather, "What is going on?"

In my case -- and this probably affects a lot of people -- the underlying culprit was Empathy. I don't use Empathy, so I don't want it to authenticate to Google Talk on my behalf. Now here's where it gets interesting. When I followed Evgeni's lead and ran Online Accounts (under System Settings), it was completely unpopulated. That's because it auto-populates when apps that hook in to Online Accounts update credentials. Since I never filled in that Access Prompt dialog box, this never happened and I had nothing to change.

The key action that's leading this behavior on startup is that Empathy defaults to "Automatically connect on startup" even if you don't actually use it. So run Empathy, go to Preferences, and under the General tab, uncheck "Automatically connect on startup".

In my particular case, I had to also stop Evolution from checking my Gmail account before this dialog box went away completely.

share|improve this answer
    
I've followed this step but it doesn't help - on logging in it gives me two serial authentication requests as described (although with a silver key rather than a shield). Any ideas what I could do, or tips as to how I could troubleshoot this myself? –  Peter Fine Feb 20 '13 at 10:58
    
I don't even have empathy installed and the same thing happens to me. –  Soroosh129 Mar 7 '13 at 11:12
add comment

Try renaming the file

~/.config/goa-1.0/accounts.conf

It worked nicely for me. Thanks to this comment: bugs.launchpad.net/ubuntu/+source/gcr/+bug/1044549/comments/14

share|improve this answer
add comment

That happened to me. You need to sign out of gmail and reboot your computer/laptop. Then sign in a it should work. Tell me if you have any problems😃.

share|improve this answer
    
It worked... temporarily. It came back. What's going on? –  bigcat42 Oct 31 '12 at 11:35
add comment

If it's for a Google account with two factor authentication enabled, generate a one time "Application-specific password" for it at the Google account security tab

share|improve this answer
    
Thanks for your answer! Can you provide a more detailed explanation on how and where to set this password? With your help beginners could also benefit from your answer. –  mrcktz Nov 20 '12 at 23:06
    
Here's Google's help page on the subject support.google.com/accounts/bin/… –  tkoopa Nov 24 '12 at 9:35
add comment

I ran into this issue because of Google's Two Factor authentication. If you want to stop receiving this prompt you need to generate an application specific password from Google.

For instructions on how to create the app specific password follow this bad boy below.

https://support.google.com/accounts/answer/185833?hl=en

Once you've followed those instructions, grab the generated password, plug it into the prompt, and be bothered no more!

(This solution was used in 13.04)

share|improve this answer
add comment

I believe the problem is that GNOME Search is checking Contacts.

There is an option in Settings -> Search to deselect Contacts, and that should save the day.

share|improve this answer
add comment

protected by Braiam Feb 27 at 23:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.