Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A pop up keeping appearing in Ubuntu (running 12.10), asking for the password to my gmail account. The icon has a silver shield, and it is labeled Access Prompt.

The actual window has an image of keys on a keyring, says “Authentication request” in bold, and “Please enter your password for the account, [gmail address]”. It keeps saying my passwords are incorrect... I'm not even sure which account it's talking about. What is going on?

share|improve this question
Same here. I'm also running 12.10. Seems to be related to the gcr package as shown in the bug report here – jairo Nov 3 '12 at 17:08
Try advice # 4 from 10 Things To Do After Installing Ubuntu 12.10 in a reverse manner, i.e. remove your online account/s. – user104382 Nov 4 '12 at 7:40
up vote 8 down vote accepted

Evgeni Leshtanski's answer clued me in to what was really happening. The question isn't, "How do I tell some random prompt what my password is?" but rather, "What is going on?"

In my case -- and this probably affects a lot of people -- the underlying culprit was Empathy. I don't use Empathy, so I don't want it to authenticate to Google Talk on my behalf. Now here's where it gets interesting. When I followed Evgeni's lead and ran Online Accounts (under System Settings), it was completely unpopulated. That's because it auto-populates when apps that hook in to Online Accounts update credentials. Since I never filled in that Access Prompt dialog box, this never happened and I had nothing to change.

The key action that's leading this behavior on startup is that Empathy defaults to "Automatically connect on startup" even if you don't actually use it. So run Empathy, go to Preferences, and under the General tab, uncheck "Automatically connect on startup".

In my particular case, I had to also stop Evolution from checking my Gmail account before this dialog box went away completely.

share|improve this answer
I've followed this step but it doesn't help - on logging in it gives me two serial authentication requests as described (although with a silver key rather than a shield). Any ideas what I could do, or tips as to how I could troubleshoot this myself? – Peter Fine Feb 20 '13 at 10:58
I don't even have empathy installed and the same thing happens to me. – Soroosh129 Mar 7 '13 at 11:12
Empathy no longer seems to have the "Automatically connect on startup" option (I have version 3.12.9 on Ubuntu 15.04). What should I do now? – A. Dueppen Jun 18 '15 at 0:34

Try renaming the file


It worked nicely for me. Thanks to this comment:

share|improve this answer

If it's for a Google account with two factor authentication enabled, generate a one time "Application-specific password" for it at the Google account security tab

share|improve this answer
Thanks for your answer! Can you provide a more detailed explanation on how and where to set this password? With your help beginners could also benefit from your answer. – mrcktz Nov 20 '12 at 23:06
Here's Google's help page on the subject… – tkoopa Nov 24 '12 at 9:35

I ran into this issue because of Google's Two Factor authentication. If you want to stop receiving this prompt you need to generate an application specific password from Google.

For instructions on how to create the app specific password follow this bad boy below.

Once you've followed those instructions, grab the generated password, plug it into the prompt, and be bothered no more!

(This solution was used in 13.04)

share|improve this answer

Your "Password was incorrect" problem is because "GMail" identifies "Evolution" as a less secure app, so doesn't provide authentication to the app. You can change this feature if you want,

But if you don't want to allow your email access to evolution, you can remove your gmail account in evolution by following these steps

  1. Open Evolution
  2. Edit
  3. Preferences
  4. Select your email account, then press "delete"

This should remove your email account from evolution and no more signing in troubles anymore.

share|improve this answer

That happened to me. You need to sign out of gmail and reboot your computer/laptop. Then sign in a it should work. Tell me if you have any problems😃.

share|improve this answer
It worked... temporarily. It came back. What's going on? – bigcat42 Oct 31 '12 at 11:35

I believe the problem is that GNOME Search is checking Contacts.

There is an option in Settings -> Search to deselect Contacts, and that should save the day.

share|improve this answer

The accounts.conf file is also used by the new Ubuntu online accounts configuration. The problem seems to be that after an upgrade the old entry from the original Gnome online accounts application is left. The new online accounts utility adds entries after the previous one which is the one causing the problem.

This is the old entry in my case from ~/.config/goa-1.0/accounts.conf:

[Account account_1388648527]
<email address hidden>
<email address hidden>

Just editing the accounts.conf file and removing just this entry solved the problem. If you remove the file you will have to rerun the new online accounts application in order to recreate your new configuration.

share|improve this answer

Removing the *.source file(s) from ~/.config/evolution/sources did the trick for me - those dialogs are gone for good. Source:

Though, in my case, this was probably due to a combination of the other answers (Google 2-factor auth) and the fact that I had upgraded from an earlier version of Ubuntu and the account configurations were left over.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.