Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have to say, firefox on ubuntu's performance is attrocious. Very quickly it gets into 100% cpu use (thank god I have multiple cores) and hundreds of megs of ram. Even closing tabs does not help the issue (unless google.com uses supreme amounts of javascript).

On the same machine chromium browser runs lightning smooth. I tried swiftfox, nothing useful there. Is this a common problem? Only recent (past 3.6) versions have even been able to scroll rather smoothly vs choppy performance when using the scroll bar on pages. The performance is getting close to running firefox on a windows xp virtual box vm.

Edit:

OS:

Kubuntu 9.10. Installed Gnome packages for Ubuntu and use those. Upgraded to 10.04.

64bit

Nvidia Proprietary Video Drivers using the Restricted Driver tool.

Hardware:

Core 2 Quad

4gb DDR2 667 ram

7200rpm hdd

Nvidia GeForce 8800

Also note for everyone responding:

The default settings work damn well in windows on the same machine. The performance in Linux is what sucks.

share|improve this question
6  
Please rephrase as a question. Do you want to know why it is slow? How to fix it? What alternatives there are (you seem to know this already)? –  dv3500ea Aug 12 '10 at 18:41
1  
All 3. I have no idea why it is slow, or how to fix it. Alternatives are google chrome but I NEED to use firefox in some cases. –  Dmitriy Likhten Aug 12 '10 at 19:18
3  
If you run "firefox -safe-mode" does it still have attrocious performance? It behaves better than Chrome on my system, btw. –  Li Lo Aug 13 '10 at 3:34
    
@Li Lo will experiment. Thanks. –  Dmitriy Likhten Aug 16 '10 at 21:45
    
I had the similar problems with firefox and thunderbird... both where eating much cpu and very slow and I changed to chrome and evolution –  Marcel Feb 8 '11 at 21:27

6 Answers 6

up vote 2 down vote accepted

I can't replicate the issues you're detailing - this seems very odd to me (and I'm speaking on the level of testing on multiple machines. This likely may be something particular with your setup.

Here are a few things that can contribute to poorer performance on a machine:

  • Clean Install v Multiple Upgrades: I had a similar issue on a workstation that had been upgraded through the years from 5.10 to 9.04 the desktop would randomly restart at odd intervals with no warning - and no log entries. I ended up doing a clean install and the issue went away. Not the best scenario where Troubleshooting triumphed but an example of how older configurations can cause weird issues.
  • Hardware: Far less likely - but it may just be an issue with that Firefox release and your setup (drivers, configuration, etc) might be conflicting - which would explain why Swiftfox (a Firefox derivative aimed at increasing performance of the Mozilla tool for Linux) is also responding poorly.

I would search for people exhibiting similar issues with Firefox on setups similar to yours ( You didn't provide anything so I can't really help you further ) but it may be a configuration, compilation issue.

share|improve this answer
    
I've already done a "clean" install of firefox. Did a complete removal using apt, even downloaded a few versions as tarballs, they all perform very sluggish for running on a core 2 quad 4 gigs ram, and a 64bit os. As for the OS, I've had these problems with firefox even after a fresh install of ubuntu. –  Dmitriy Likhten Aug 12 '10 at 19:19
    
Did you remove the "~/.mozilla/firefox" folder? I suspect extensions are at fault. –  Li Lo Aug 13 '10 at 3:36
    
FF is quite fast even in my netbook (Atom + 2 Gb). You need to give us more information about your setup. Is it as slow when you are running it from a live session?. –  Javier Rivera Aug 13 '10 at 16:30

There's a possibility that the sqlite database that Firefox uses becomes too fragmented and reading that could grind the hard drive for a minute or two (especially if you like me have hundreds of bookmarks and never delete history)

The solution to this is the Vacuum Places Improved addon (link text). It defragments your sqlite database, and the startup performance is markedly improved (at least for me it did). Maybe that will work for you.

share|improve this answer
    
Improve DNS lookups with dns speed addon: addons.mozilla.org/pt-br/firefox/addon/speed-dns see Author comment: I recently watched on how Chrome browser improved its performance by speeding up their DNS lookups. I wanted to do the same for Firefox and hence this add-on. You can read more about it here - chrome.blogspot.com/2009/12/… and view more here - youtube.com/watch?v=FhDDwmOyRmk –  user3798 Oct 10 '11 at 13:16

I found this http://ubuntuguide.net/optimize-and-make-firefox-running-faster-than-google-chrome

share|improve this answer
1  
Does not address the problems of extreme cpu utilization and choppy scrolling and such. –  Dmitriy Likhten Aug 16 '10 at 21:40

I agree with Macro for the most part. I had a similar issue, but Google Chrome might be useful. :) or if you really want Firefox try one of the betas and hope they fixed the issue or by virtue of new code it fixes itself.

fingers crossed

share|improve this answer
    
It's been getting better since v3.6, but still pretty bad even compared to how it works in windows. –  Dmitriy Likhten Aug 12 '10 at 19:35
    
I would then just say switch to chrome. :) Sorry mate –  myusuf3 Aug 12 '10 at 19:52
    
For me Google Chrome has as many problems as Firefox has. –  txwikinger Aug 12 '10 at 20:07
    
I can't switch to chrome. I need firefox, one of many reasons being that its a target platform of my webapp, especially that its one were officially supporting, and chrome's developer tools have lots of catching up to do compared to firebug. Not to mention that chrome's tools often crash. :( –  Dmitriy Likhten Aug 12 '10 at 20:11

Some possible steps to increase performance:

  • Make sure you only have the extensions installed that you absolutely need
  • clear your history, cache, cookies etc.
  • Set it so that Firefox doesn't remember history.
  • Disable flash and java plugins if you don't use them.

Other browsers you could use when you don't need firefox:

  • chromium/chrome (package: chromium-browser)
  • midori (package: midori)
  • epiphany (package: epiphany-browser)
share|improve this answer
    
Using same extensions as on windows. History point is BS, I think a 4-core, 4 gig ram computer can handle a bit of cookies/history (and I need cookies). Need flash. Java never runs. –  Dmitriy Likhten Aug 13 '10 at 14:54

When Firefox starts eating CPU, I find that most of the time there are pages with Flash animations being the culprit.

Try installing the Flashblock addon and see if that helps. This addon prohibits embedded Flash animations/videos from running until you click on them.

share|improve this answer
    
Have that for a long time :) I know flash is a killer in linux, so thats the first thing I get. –  Dmitriy Likhten Aug 13 '10 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.