Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've done an upgrade from 12.04 to 12.10 on a PC with an i7 processor, an nvidia GT630 card video card and an Intuos 2 tablet. Everything went smoothly until I tried to also upgrade the nvidia drivers using the additional drivers tab in the Software Sources application.

Now the tablet is recognized (it shows up in the output from lsusb and xsetwacom --list devices) but neither the Wacom mouse or pen controls the cursor. By plugging in a USB mouse I do get a working mouse. The strangest part is that occasionally the tablet works but I can't find any pattern to when this happens. I've tried all the different nvidia drivers, but the problem is the same.

Possibly coincidently or they may have been there before and I didn't notice them, I now get some messages on shutdown that I don't know the meaning of:

Rather than invoking init scripts through /etc/init.d use the service(8) utility, e.g. service S35 networking stop initctl : unknown job S35networking

Since the script you are attempting to invoke has been converted to an Upstart job, you may also use the stop(8) utility, e.g., stop S35networking

Is there a way to repair my installation or should I just do a fresh install of 12.10?

share|improve this question
    
There is always a way to repair an installation. But first, if you have a live USB/DVD I would test it out on that to see if the problem is your install or the OS update. There have been major changes in the drivers for drawing tablets in the linux kernel since 12.04 was released, but mostly for non-wacom support. –  bntser Oct 27 '12 at 20:00
    
Tried a live USB version of 12.10 and the tablet worked correctly with the nouveau open source driver. –  Richard Quint Oct 28 '12 at 6:31

1 Answer 1

I would recommend a fresh install; it might be possible to pick through what is causing the problem (and it might be interesting to do so) but the fastest way to cure the problem is probably going to be a fresh install of 12.10.

It's certainly not a problem I've seen before.

share|improve this answer
    
I haven't much luck pining down the problem. The tablet worked for a couple weeks and then stopped again. When I booted into Windows7 it always worked, so I don't think there is anything wrong with the tablet. I've now swapped tablets with another PC (the new one is a Wacom Graphire4) and I've got a working tablet again. I've tried all the various nvidia drivers, current, current-update, experimental, very experimental and nouveau-with the same behaviour every time. –  Richard Quint Dec 5 '12 at 2:02
    
I don't think it's an issue with nvidia. That's probably a false correlation. More likely either a very subtle hardware glitch that the Linux wacom drivers can't cope with, or some setting somewhere is trashed. Try using the tablet from a LiveCD (boot from USB or CD) and it should work. If not, it's most likely a hardware issue. –  Martin Owens -doctormo- Dec 10 '12 at 18:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.