Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Nautilus's sidebar partitions broke after a new fstab and an upgrade to Quantal.

I made a new fstab after putting it off for several months, and now Nautilus doesn't show anything in the "Devices" pane. They still do show up their contents if I manually navigate to /mnt/whateveriassigneditto, but I miss quick-and-easy access from the sidebar. Is this related to my upgrade to 12.10 or something else? Is there any fix that does not involve replacing my UUID references with /dev/sdax? (I have very dynamic partitioning layouts; Windows tends to crap out on me often.)

The missing "devices" pane

My fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
#
proc                                     /proc           proc    nodev,noexec,nosuid 0       0
#
# / was on /dev/sda8 during installation
UUID=3603e7ad-aa27-4487-acc9-486401fb03cc /               ext4    errors=remount-ro  0       1
#
# swap was on /dev/sda7 during installation
UUID=47313ea9-05b2-409c-9954-6664a505d743 none            swap    sw                 0       0
#
# hopefully will mount primary Windows install
UUID=4A5CC6CE5CC6B3CB       /mnt/Windows7    ntfs-3g      quiet,defaults,locale=en_US.utf8,umask=0,exec,user,rw     0 0
#
# Small ramdisk for faster acess times
tmpfs           /mnt/tmpfschk   tmpfs        size=100m                                           0 0
#
#
# Less important volumes:
# Acer Recovery Partition (primary)
UUID=56686A4C686A2AC7       /mnt/Recovery    ntfs-3g      quiet,defaults     0 0
#
# Acer Recovery Partition (logical)
UUID=1C15E94C686A2AC7       /mnt/Recovery2    ntfs-3g      quiet,defaults     0 0
#
# Backup Windows Install (Blank settings and stuff)
UUID=49E82E265CC6B3CB /mnt/WindowsBackup    ntfs-3g      quiet,defaults     0 0
#
#
# Fedora
UUID=6ad48b44-99e9-425b-996f-c6d288dfee79 /mnt/Fedora ext4 errors=remount-ro 0 0
#
# Fedora's Swap Partition
# UUID=9ec7bbb1-2b30-4f8e-9a4a-5355925a3c9d none swap noauto 0 0
share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I've had experience with vanishing menu entries, although in my case it was what I wanted!

I believe the problem is that Nautilus doesn't show external media that aren't mounted under /media. So by mounting under /mnt (which, by the way, is usually left as an empty folder to mount to directly in case the sysadmin needs a quick mount point), you are hiding them yourself!

There are two solutions. First, mount them under /media. This is quick and painless.

Second, you could write a udev rule that tells udisks to recognize them (Nautilus uses udisks IIRC), even though they're mounted somewhere else. I haven't tried this method, but it might work. Make a udev rule, like /etc/udev/rules.d/10-showdrives.rules, and put in it the following:

KERNEL=="sda[0-9]", ENV{UDISKS_IGNORE}="0"

Or if you want to use UUIDs (a good idea), have one line looking something like the following for each of your volumes.

SYMLINK=="disk/by-uuid/YOUR_UUID_HERE", ENV{UDISKS_IGNORE}="0"

If the latter doesn't work, rename the file to something like 99-showdrives.rules to let udev make symlinks.

I adapted this from the opposite advice (which I have tried; it works) at the Arch Wiki page for KDE.

share|improve this answer
    
Awesome! Thanks. I'll try mounting under Media and seeing whether the double-drive bug still happens in 12.10; if it does I'll try your second method. –  WindowsEscapist Oct 27 '12 at 21:19
    
I didn't know that about /mnt; I've only manually done stuff with /mnt with older (Puppy) linux where there was no /media. Thanks! –  WindowsEscapist Oct 27 '12 at 21:20
    
Yeah, instead of /mnt, I usually use openSUSE's convention of mounting Windows volumes under /windows. ("Screw the FHS!" :) Of course, this will hide your volumes in Nautilus (which is what I like). –  thirtythreeforty Oct 27 '12 at 21:24
    
Great, drives are all displayed in nautilus's sidebar after mounting under /media/x! It all works. (Delay was 'cause I borked my ubuntu by doing something else, I had to edit burg.cfg from fedora.) –  WindowsEscapist Oct 27 '12 at 22:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.