Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Upstart conf file in /etc/init which starts fine if i start it manually like this:

sudo initctl start myconf

If i run it without the sudo command i get the error name=(unset) error, which is due to user privileges, but that shouldn't be the problem when the job is initialised at system boot when Upstart kicks in right? (because thats all run by the root).

The content of the script is:

start on runlevel [2345]
stop on runlevel [^2345]

exec /spatial/

...where the runs a python script based server. When i check the status of the script right after i login to shell, it says stop/waiting. I also tried the conf file with "start on net-device-up" but nothing changes. Is there a way to see the Upstart system log or something similar that might help me debug the problem.


share|improve this question
Sometimes if you have a chdir in your upstart script and that dir doesn't exist, no log will be written and you'll get the cryptic message: start: Job failed to start – knownasilya Nov 14 '14 at 16:38
up vote 9 down vote accepted



You may want to consider converting it to a task while you debug it.

start on spatial-start


exec /spatial/

then from the console:

initctl emit spatial-start
initctl status spatial-start
share|improve this answer
Will also give it a shot, thanks. I assume this actually outputs Upstart specific issues; does it include syntax errors in conf files also? – U2ros Oct 30 '12 at 19:41
This is where stdout/err is redirect so it had better be verbose. – ppetraki Oct 30 '12 at 20:20

Okay, found one way, but it only works if the error happens in the program that is being executed by the script (and if that program of course returns error messages), not Upstart itself, but that is what i needed in this case. What i did was redirect the program output to a log file like this:

exec /spatial/ >> /spatial/ogc.log 2>&1

As for the other i found out you can increase Upstart verbosity so if i ll need that, i ll start from there.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.