Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded to 12.10 and then downgraded again to 12.04 LTS because of the screensaver or screen blanking problem. After 10-12 minutes the screen goes black/blank when i dont do anything (idle). I have tried setting in the Brightness and Lock menu that the screen should never lock or turn off if idle. This is very annoying when watching movies etc.

Would be nice if someone knows this.

share|improve this question

7 Answers 7

up vote 6 down vote accepted

I'm not certain which one thing fixed it, but here's what I did:

  • Open dconf editor from the Dash
  • Click on the Find, and type power (case-sensitive).
  • Here's what I've got set:

    • idle-brightness = 0
    • idle-dim-time = 0
    • sleep-display-ac = 0
    • sleep-display-battery = 0
    • sleep-inactive-ac-timeout = 0
    • sleep-inactive-battery-timeout = 0

Try setting those and see if it helps you. Again, not exactly sure which one thing fixes it, I haven't taken the time to check. And ultimately, one shouldn't have to do this in the first place.

share|improve this answer
    
Cool i´ll try it and tell you if it works... Its just annoying that when idle or watching movie you must always have the mouse beside you... –  Ramon J. Strauff Oct 27 '12 at 16:19
    
Thanks... It worked... Now i can watch movies without the need of my mouse beside me... Thanky you... –  Ramon J. Strauff Oct 27 '12 at 18:33

Updating the settings using the Dconf-Editor didn't work for me.

I found this bug report -> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1072531.

Part of the bug report was a work-around.

Try running "xset s 0 0" from the command line, this fixed the problem for me.

share|improve this answer

This worked for me:

Open Dconf-Editor from the Dash.

Org -> Gnome -> Desktop -> Screensaver. In the window that appear, uncheck the line idle-activation-enabled and uncheck the line ubuntu-lock-on-suspend.

Another option is: on the left side, just below the voice Screensaver you see Session. Click on that and in the window that appears, the first line says idle-delay, the value is in seconds so maybe you can change the default value of 600 sec into a much higher value.

The movie-player Totem has a function in Preference -> Visualization, there is a line: Disable screensaver, you should check Video-audio. I hope it helps. If not, put everything back as default.

share|improve this answer

Temporarily Disable Screensaver in Ubuntu 12.10 with Caffeine

By default Ubuntu goes to sleep by turning the screen blank or dark every ten minutes of inactivity. This can be very annoying when watching a move or flash video and your display keeps going dark. While Ubuntu has built-in setting that you can use to disable the screensaver, some users are saying the it doesn’t work after applying the settings.

This brief tutorial is going to show you a little tool that will help you temporarily disable Ubuntu from going to sleep while inactive for some time. It is called Caffeine. After installing, you have it automatically started everytime you login to Ubuntu or choose when to turn it on. Before watching a movie in Ubuntu, launch Caffeine and configure it to temporarily disable Ubuntu sleep mode while watching the move.

It can also be configured to automatically kick in when watching online flash movies as well.

So, if everything else fails and Ubuntu is annoying the hell out of you, install Caffeine and give it a try.

To get started, press Ctrl – Alt – T on your keyboard to open the terminal. When it opens, run the commands below to add its PPA.

sudo add-apt-repository ppa:caffeine-developers/ppa

caffeine_ubuntu12_install

Next, run the commands below to update your system as well as install Caffeine.

sudo apt-get update && sudo apt-get install caffeine

caffeine_ubuntu12_install_1

After installing Caffeine, go to Dash and launch Caffeine’s preferences. Choose the preferences of your choice and close out.

caffeine_ubuntu12_install_2

Before watching a move, select Caffeine from the tray menu and select ‘Disable Screensaver’

caffeine_ubuntu12_install_3

That’s it! Sit and enjoy your movie.

share|improve this answer
  1. open xorg.conf

    sudo gedit /etc/X11/xorg.conf

  2. add following lines and save

    Section "ServerFlags"
        Option "BlankTime" "0"
    EndSection
    
  3. restart...

    • ...either system

      sudo shutdown -r now

    • ...or display manager

      sudo /etc/init.d/lightdm stop

      Ctrl+Alt+F1

      log in

      sudo /etc/init.d/lightdm start

share|improve this answer

For me, with an Asus X201E Netbook, after trying the DConf-Editor settings, nothing seemed to change, so according to one of the other answers, I tried the xset s 0 0 method and it works

Unfortunately, I had to be doing this with every session and every restart. In order to avoid doing this manually each time, I went to startup applications and inserted it as a new command. Its run each time you log into ubuntu so there is no need to mess around with the command line each time

share|improve this answer

Type "Appearance" into Dash, click on "All Settings", then "Brightness and Lock" and unclick the radio button "Dim screen to save power". Worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.