Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 12.10, by default, the minimize speed had been kept considerably slow in order to let users know where the window has minimized to...

but all of a sudden i noticed that now the speed is as normal as earlier versions! has there been an update that again increased this speed?

share|improve this question
add comment

2 Answers 2

up vote 9 down vote accepted
+100

The animation changes actually not on the minimize-speed-threshold. Even when you change the value of it from 100 to 0, the animation is still normal like what you encountered @Nirmik. What I observe though, if the minimize-speed-threshold is set to 100 (by default), and the minimize-count is set to 0 (by default), the animation is slow just like when we first run 12.10 after upgrading/installing it.

Now, the animation will actually gets faster every time you minimize a window, since the minimize-count will increase, and the more it goes to larger value the faster the animation. The increase in value of minimize-count will stop up to the value of the minimize-speed-threshold.

If you click on the minimize-count, you will see the description that says:

This is used to adjust the animation speed by making it progressively faster the more it is used.

For Slow Animation, I suggest to set up the following:

minimize-count = 0
minimize-fast-duration = 1000
minimize-slow-duration = 1000
minimize-speed-threshold = 0

For Faster Animation, I suggest to lower down the value of minimize-fast-duration and the minimize-slow-duration.

share|improve this answer
1  
Amazingly awesome answer! Thanx! heres a +100 bounty for the excellent explaination! –  Nirmik Nov 3 '12 at 9:25
    
And Canonical and ubuntu team...amazing logic! I loved it! the more you use,the more you are used to it and thus the speed can be increased! awesome thinking! –  Nirmik Nov 3 '12 at 9:26
    
...ill be allowed to grant the bounty after 23hrs...ill do it then and there ;) –  Nirmik Nov 3 '12 at 9:27
    
I'm glad that helps you @Nirmik. One thing though, after restarting my computer, the minimize animation speed will get to normal from slow. And when checking it to the dconf-editor, the settings are the same, but you need to retype the values for the animation speed to take effect again. I don't know if you notice this. But that happened to me. –  Al-Ahmadgaid Asaad Nov 3 '12 at 12:17
add comment

Yes. According to OMG! Ubuntu!, the minimize animation has been made slower. They offer a solution as to how to restore old behavior, too:

The tool we need to use to ‘edit’ the speed is called ‘dconf-editor‘ and can be be installed as part of the dconf-tools package.

When installed launch it from the Dash by searching “dconf”

When the Dconf-window opens expand the following sections of the sidebar:

com > canonical

then click on (but don’t expand) the ‘unity’ entry.

Select the following line in the main section of the window:

minimize-speed-threshold

Double-click on the value field (the number) to edit it.

Change the value from ’100′ to ’0′.

Changes take effect immediately.

I don't know why the animations seem to be back to normal... Maybe the animations reset themselves after the user has learned where apps go? Lemme know if your minimize-speed-threshold is somehow at zero; I'm curious.

share|improve this answer
    
its still 100 but the animation is still faster than before! –  Nirmik Oct 30 '12 at 18:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.