Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to present a full screen slideshow using OOo Impress, but the top panel stays on top of the slideshow. I went to Slideshow->Slideshow Settings... and made sure Always on top was checked.

How can I fix this?

share|improve this question
    
Have you tried selecting the window Right Click > Always On Top? –  Marco Ceppi Aug 12 '10 at 18:59
    
@Marco: Yup. Didn't work either. –  Nathan Osman Aug 12 '10 at 19:17
    
Does it vary depending on whether you use Metacity or Compiz? –  maco Aug 12 '10 at 21:21
    
Hmmm... I've only tried it out with Compiz. –  Nathan Osman Aug 13 '10 at 1:14

3 Answers 3

up vote 1 down vote accepted

Unfortunately this is a bug in Ubuntu and there is no fix available yet.

The bug is tracked here but unfortunately most of the workarounds didn't work for me. Feel free to try them on your system:

As funnylife_ma mentioned, you could either disable compiz (not ideal) or you could just disable the Place Windows plugin. Simply trying to untick Place Windows didn't work as after a few seconds it would be re-enabled (I assume another plugin required it). To do this I had to go into CCSM > Preferences > Plugin List, un-tick Automatic Plugin Sorting (and acknowledge the warning saying I know what I'm doing) then disable Place. Not ideal but a lot better than auto-hide panels or no compiz.

--or--

Go to System - Preferences - Conmpiz Config Settings Manager

In this screen click on utilities on the left, click on workarounds on the right. Put a checkmark for the enable legacy full screen support

--or--

Install OOo from openoffice.org like this

The workaround that works is to disable Compiz by setting Visual Efects to None in System → Preferences → Appearance.

share|improve this answer

Try to set Visual Effects to None in Appearance Preferences.

share|improve this answer

There are two things you can do:

  1. F11 that puppy before you full screen. I hopefully that will help with the panel.

  2. If not I believe this thread has a possible solution to your problem.

Keep me posted, let me know if they works with you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.