Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set up my computer with Ubuntu Server temporally for a minecraft server lan party i have port forwarded the correct ports but when trying to connect i get Connection refused: connect or Connection timed out: connect when i try to ping the local ip i get Destination host unreachable. it works fine if i plug in an Ethernet cord but at the party i will not have that option and there for need help allowing connections to come in from wlan0

any help is greatly appreciated

share|improve this question
    
Same problem, incoming ssh connections work fine over eth0 (wired) but are ignored over wlan0 (wireless). Also interesting: I can see the requests coming in in /var/log/syslog, but sshd doesn't connect it. –  cmc Nov 19 '12 at 13:14

1 Answer 1

up vote 1 down vote accepted

I found it.

Apparently, firestarter is installed on Ubuntu 12.04 either by default or as a dependency or recommendation to something I normally install. It was present on two different 12.04 machines but I don't remember installing it. Also never heard about it anywhere.

Firestarter only considers one of your network connections your internet gateway, and by default that's the wifi. So it sets up your linux firewall to block all incoming connections for wifi, but not ethernet, because it considers ethernet to be your local network.

The tricky part is that ufw and gufw, which seem to have replaced firestarter as Ubuntu's recommended firewall, have their own set of iptables rules, so they don't even notice firestarter is there and can't switch it off.

To get rid of the firestarter rules temporarily, launch firestarter and click the stop button.

To get rid of firestarter and its rules permanently, do:

sudo apt-get remove firestarter

You can now either leave the firewall as it is and possible disable samba when you're on public wifi, or you can set up a couple of rules of your own with ufw or gufw. I just left if off and plan to switch on gufw by hand if I go on public wifi.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.