Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have seen issues close to my problem but no one seems to have a definitive answer as to what is going on and why the failure occurs. I have a number of NAS devices on my home network and on a previous install of 12.04 and version prior mounting at login worked using this entry for each in fstab:

//servername/sharename /media/windowsshare cifs    guest,uid=1000,iocharset=utf8,codepage=cp850,cp850 0 0

Now when I use this, 12.10 reports the standard - cannot mount bad option ... blah blah...

The kern log reports that the CIFS option "codepage" unknown... changed entry to "unicode" and received the same error message. There are no other error messages or log entries that would indicate another issue, but this is the statement I used for quite awhile with version 12.04 and before.

Is the codepage option obsolete in 12.10/CIFS now? Is there a codepage support program that I must load? Is there some kind of helper program that is required to supports the codepage option?

A current review of the man pages at does not make mention of the option "codepage".

Extremely confused - any help/insight would be greatly appreciated.

share|improve this question

codepage option is longer time obsolete, but now you cannot mount with this option in /etc/fstab

So remove this option and try again.

share|improve this answer

I had similar problems since my upgrade to 12.10 and solved them through installing cifs-utils:

sudo apt-get install cifs-utils
share|improve this answer

You need to remove the following mount options, as it appears that they' are no longer supported:


I had pretty much the same line in my fstab, except my encoding was unicode instead of cp850.

//                   /media/nas      cifs    guest,uid=noel,gid=noel,iocharset=utf8,codepage=unicode,unicode 0       0

Once I removed codepage=unicode,unicode, it mounts for me at boot time. My working configuration is:

//                   /media/nas      cifs    guest,uid=noel,gid=noel,iocharset=utf8 0       0
share|improve this answer

I don't have an answer for you but I do have the same problem. I used to mount windows shares via the terminal with the "mount -t cifs //IP/share -o username" line but it gives me the error as well. This doesn't answer anything but I notice if I mount directly from the desktop ("connect to server") and use all caps in every field but the IP address of the server and my user password, it will mount correctly. Hope this helps.

share|improve this answer

Remove the parameters "codepage=unicode,unicode" from your mount option in /etc/fstab.

Worked for me!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.