Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My LCD monitor won't enter power save mode.

I've gone into SystemPreferencesScreensaver, clicked Power Management, then set Put display to sleep when inactive for: to 10 minutes (for both On AC Power and On Battery Power), but the monitor still doesn't enter power save mode, even after an hour.

Anyone have ideas on what to try?

I'm using Ubuntu 10.04.1 LTS 64-bit desktop on a Dell Latitude E6400 laptop.

Update Sun Jan 16 01:02:45 PST 2011:

I forgot to mention the laptop is docked, and the monitor is connected via DVI cable to the dock. I haven't tried waiting for power save mode using a VGA cable or no dock.

share|improve this question
1  
What video card are you using? Control over the power save functionality is highly dependant on a fully working graphical driver. –  Martin Owens -doctormo- Jan 9 '11 at 3:52
    
lspci says "Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)". dmesg says "Intel Mobile Intel® GM45 Express Chipset". I should also add that power save mode has worked with this laptop before, with this monitor and other monitors. –  Adam Monsen Jan 10 '11 at 16:37
    
It's likely just that your system does not communicate to the monitor to enter powersave mode until you close the lid, because of either the connection, or a short coming of the driver. –  RolandiXor Apr 16 '11 at 13:43
add comment

4 Answers

up vote 4 down vote accepted

I also have this problem and I learned a lot trying to fix it. I couldn't find a GUI fix to this. I'm on a Dell Latitude D630 running 10.10, which is docked and runs two 23" LCDs.

Here's what I did, and what you can try:

xset s XXX

where XXX is the number of seconds you want the pc to be idle before it suspends/poweroff your monitor

xset dpms 0 0 900

The first zero is for standby, second is for suspend, and third is the off setting. This will turn off my monitor in 15 minutes if left idle.

You can test dpms standby, suspend and off settings with:

sleep 1; xset dpms force standby

You can replace the word "standby" in the command above with suspend or off. In my testing, they all did the same thing; they each powered off the monitor (blacklight completely off). When I moved my mouse to wake the monitors, each command did it equally as fast. For my situation, I stuck with off.

xset -q

The above command gives you interesting details about your screensaver and DPMS settings. When I ran this command before changing anything, it says

Screen Saver:
prefer blanking:  yes    allow exposures:  yes
timeout:  0    cycle:  0

and

DPMS (Energy Star):
Standby: 0    Suspend: 0    Off: 0
DPMS is Enabled
Monitor is On

On a fresh boot, the timeout and cycle value under Screen Saver are 600. Over time, they change to the above. This is a bug, and I'm sure its been reported @ launchpad.net. I couldn't find the appropriate bug report (if someone does, please share a link).

Now, specifying the commands above do not persist after you log out. The only way I could get it to work was to create a file called xset-start.sh in my home directory.

In the file I have:

#!/bin/bash

/usr/bin/xset dpms 0 0 900 &

You need to give the file execute permissions, otherwise it wont work. Open a terminal and run:

chmod u+x xset-start.sh

To have startup at logon, do the following:

  1. Go to System -> Preferences -> Startup Applications
  2. Click Add
  3. You can name it xset-startup
  4. Browse to your home directory where xset-setup.sh is
  5. Give the startup entry a comment if you'd like and click Add when finished.

Test it by restarting your computer. After restarting, open a terminal and run

xset -q

make sure the off value for DPMS is 900.

I'm sure there are global files and other per-user startup files this could go in.

this post: External monitors don't go into standby if laptop lid is closed states that the external monitors go to sleep properly if the lid is open on the laptop. I didn't test this, but it made me think if the laptop lcd is disabled in the "Monitor" preferences, are the dpms settings being honored by the external monitors?

References:

  1. xset manpages
  2. Custom X Session
  3. A Primer on Screen Blanking Under Xorg
  4. How to turn off the display via the command line?

Tips:

  1. How can I put the display to sleep on screen lock?
share|improve this answer
    
I don't have the laptop any longer so I can't confirm, but I'm going to go ahead and mark this as the accepted answer anyway. –  Adam Monsen Jun 17 '11 at 17:37
add comment

I found a solution. In the Monitor Preferences (started either via gnome-display-properties from the command line or by clicking on the monitor icon in the panel, then choosing "Configure Display Settings ..."), there's a visual representation of both monitors. If I drag the LCD monitor around such that it appears to the left of the laptop display, the monitor properly goes into power-save mode. Yay!

share|improve this answer
    
Argh, nevermind, this doesn't always work. –  Adam Monsen May 31 '11 at 16:32
add comment

Sometime you need a PC, who never ends his display (advertising sliders). You can use a crontab -e to put similar task, so that every seconds get increased)

e.g:

$ crontab -e
*/5 * * * * xset s 86400

Note: i am using this in my crontab, where i need to display 24/7 advertising

share|improve this answer
add comment

In Xubuntu 13.04 (xfce 4.10), the dpms commands mentioned by MystaMax worked for me. In addition, I found that in the XScreenSaver Preferences (Menu > System Settings > Screensaver) on the Advanced tab is a section labeled "Display Power Management". Those values are persisted for me, as shown by running xset -q after setting them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.