Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble with Ubuntu. It was working fine on Weds 24/08/12. Fired up my laptop yesterday and came up with the Grub screen.

What I basically want to know is how do I get back to normal service?

I'm pretty illiterate when it comes to Ubuntu/Linux systems.

I think I'm running the latest version of Ubuntu. Currently using the 11.10 trial which I burnt to disc to use my laptop at the minute to post this question.

This is the first screen I get come up. ''

Following the first option it just takes me to a black screen with a flashing underscore. Pretty sure it doesn't allow me to enter any text.

When I follow the second option I get this screen:


I've tried following the advice on this question, but it hasn't done the trick. It keeps asking me if it's mounted.

Any help will be appreciated. Ideally I'd like to get things back to normal. Failing that copying my data from the hard drive to an external one and reinstalling Ubuntu would be fine.

share|improve this question
It looks like it is complaining about the ext4 filesystem. Have you tried a live cd and seeing if you can mount the drive in ubuntu live? – zanegray Nov 3 '12 at 22:49

Are you able to boot from a LiveCD? If you are, please open 'Terminal' (go to Ubuntu icon > click and type 'term') and type sudo fdisk -l in the Terminal application. Paste the output of the command here. Also take a look at this wiki article Grub2/Installing

If you feel that you are unable to follow the steps or it just doesn't work...Backup your important data to a USB drive while using the LiveCD and reinstall the whole OS.

share|improve this answer
ubuntu@ubuntu:~$ sudo fdisk -l Disk /dev/sda: 250.1 GB, 250059350016 bytes 255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x0005dd54 Device Boot Start End Blocks Id System /dev/sda1 * 2048 482252799 241125376 83 Linux /dev/sda2 482254846 488396799 3070977 5 Extended /dev/sda5 482254848 488396799 3070976 82 Linux swap / Solaris – Russ Nov 12 '12 at 11:02
That's what I get. I'm booting from the CD and using the 'Try Ubuntu' option. However I am unable to access any of my data. Whilst I had the most important stuff backed up there were some additional files which I didn't back up! – Russ Nov 12 '12 at 11:02
Tried installing version 11.xx alongside 12.04. I wasn't able to do it due to a problem with ext4. Couple of the messages that popped up read unable to mount /root/dev and a couple of other similar ones. – Russ Nov 12 '12 at 11:52
What happens when you try to open your partitions in the file manager (in a live session)? If you're able to open your partitions please transfer the relevant data to a USB or another location, then reinstall Ubuntu 12.04. – koogee Nov 12 '12 at 14:01
You can try mounting partitions (i.e. /dev/sda1) manually. Search the Ubuntu wiki for instructions on how to mount partitions manually. It's quite easy. – koogee Nov 12 '12 at 14:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.