Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 12.10 and I'd like to install geary 0.2.2. When I type ./configure, it shows:

peng@peng-ThinkPad-SL410:~/Downloads/geary-0.2.2$ ./configure

cmake version 2.8.9

-- The C compiler identification is GNU 4.7.2
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Icon cache will be updated
-- Desktop database will be updated
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26") 
-- xgettext found
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  Could NOT find Vala (missing: VALA_EXECUTABLE)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindVala.cmake:55 (find_package_handle_standard_args)
  src/CMakeLists.txt:269 (find_package)


-- Configuring incomplete, errors occurred!
Unable to prepare build directory.
share|improve this question

1 Answer 1

up vote 4 down vote accepted

KEY -> Could NOT find Vala (you need to install vala)

Building & Running

To fetch a copy of the source from Yorba's git repository:

$ git clone git://yorba.org/geary

Geary requires Vala 0.17.4 (or higher) and cmake. It also requires the developer packages (headers) for the following packages:

canberra
gee-1.0
gio-2.0
glib-2.0
gmime-2.6
gnome-keyring-1
gtk+-3.0
notify
sqlite3
unique-3.0
webkitgtk-3.0
indicate (optional; enables support for Ubuntu Unity messaging menu)
unity (optional; enables support for Ubuntu Unity launcher)

Most of these are standard libraries available from major distros' repositories.

On Ubuntu 12.04, you can install Vala 0.17 from the Vala PPA, which you can add to your system as follows:

ppa:vala-team/ppa Launchpad logo (Click here for instructions on using PPAs.)

$ sudo add-apt-repository ppa:vala-team/ppa
$ sudo apt-get update
$ sudo apt-get upgrade

On Ubuntu 12.10, you don't need to add any PPAs (Vala 0.17 is available in the valac-0.18 package in the official repositories).

On Ubuntu 12.04 or 12.10, you can obtain the dependencies for Geary with these commands:

$ sudo apt-get install valac-0.18 cmake libcanberra-dev libgee-dev libglib2.0-dev libgmime-2.6-dev \
       libgnome-keyring-dev libgtk-3-dev libnotify-dev libsqlite3-dev libunique-3.0-dev \
       libwebkitgtk-3.0-dev libindicate-dev libunity-dev

You should check that you are using the right version of valac with the command

valac --version:

Vala 0.17.4

The version number must be at least 0.17.4. If it reports an earlier version, run

$ sudo update-alternatives --config valac

and select 0.18 there.

To build:

$ cd geary
$ ./configure
$ make

After building, Geary can be installed with:

$ sudo make install

and removed with:

$ sudo make uninstall

Running

Once compiled, Geary can be run straight from the build directory:

$ ./geary

It will prompt for a username and a password. Geary will then fetch all the account folders and load the most recent messages from the Inbox.

SOURCE -> improve format, step order and so on http://redmine.yorba.org/projects/geary/wiki


if you don't want to compile you can use :

for ubuntu <= 12.04 , “Yorba” team

ppa:yorba/ppa Launchpad logo (Click here for instructions on using PPAs.)

for ubuntu = 11.10, 12.04, 12.10 , “Yorba” team Daily Builds

ppa:yorba/daily-builds Launchpad logo (Click here for instructions on using PPAs.)

$ sudo apt-get install geary
share|improve this answer
    
YOU ARE THE REALLY EXPERT IN UBUNTU!Could you please have a look at this question Unable to locate package lightread Thank you : ) –  J.A.F Oct 26 '12 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.