Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04.1 LTS AMD64 on an old Dell D630 with 2x 1 TB HDDs in a RAID1 array. The second disk is located in the D630's media bay where the CDROM used to sit. This setup works perfectly.

BUT: When both disks are in place, the system goes into GRUB rescue on boot and says "out of disk".

As soon as I remove the HDD in the media bay, it boots correctly. I have not tried removing the internal HDD. I can push the media bay HDD back into the system right away before boot continues and then I don't even need to rebuild the RAID.

Of course, I installed GRUB on both disks.

I checked and re-checked the cfg files, but everyting seems fine.

md1 : active raid1 sdb5[0] sda5[1] 11881408 blocks [2/2] [UU]

md0 : active raid1 sdb1[0] sda1[1] 964878272 blocks [2/2] [UU]

lspci:

00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)

00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)

share|improve this question
add comment

2 Answers

Couple things here, your old Dell may not be able to handle large disks without some tweaking, it could have misreported the size at boot and grub is just the victim of that, GIGO. Does it matter which disk you remove? If the error only corrected itself when a unique member is removed, that would be an interesting clue.

The file system you run can also affect things. As grub does have to co-exist with it. There's a 1MB space at the beginning of the disk for grub environmental vars that's supposed to be available but sometimes goes awry when you use something like btrfs.

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/477430

Considering it's an old system/BIOS, you may need to keep the first partition small, under 137 MB. Though if I'm reading your blocks right, md0 is under 120MB and MD1 has the remainder of the 1TB disk. That should be OK, unless I calculated that wrong?

share|improve this answer
    
When I remove the internal hdd and try to boot from the media bay hdd, I get the GRUB rescue system saying out of disk. Boot order is set correctly to boot from internal hdd first. When both are in place, I also get the GRUB rescue system saying out of disk. When the internal is alone, it works. The root file system is on md0, ext4. md1 is swap –  vario Oct 26 '12 at 13:38
    
The Latitude D630 is not that old, it is 64bit after all and the bios is A17 from 2010. The bios reports the size correctly in the BIOS setup. Is there a way to determine what the bios reports to grub? –  vario Oct 26 '12 at 13:53
    
Concerning "old", I simply took your word for it :). Back to partition sizing, /boot has + sizeof(md0) (since swap is first), which may be part of the problem, just another variable to keep in mind. Concerning grub debug verbosity, the answer is probably yes, but you'll need to dig into the docs to find out. –  ppetraki Oct 26 '12 at 14:23
    
What happens if you swap the physical position of the disks? Does the fault follow the disk or the port? –  ppetraki Oct 26 '12 at 14:24
1  
Thanks for "taking me by the hand" here ;-) I swapped the physical positions and now it works. I can choose either disk to boot in the BIOS and boot successfully. I am not entirely happy because the root cause has not been identified, but I'll leave it at that. –  vario Oct 27 '12 at 5:50
show 1 more comment

I got the same error when installing Mint in a too big disk on a laptop. A re-partitioning for the BOOT partition (/root, /boot) disk to ~20GB and /home to rest solved my problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.