Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10 and I really want to use two-finger scrolling on the Synaptics TouchPad.

I can't activate it in the System Preferences because the checkbox is disabled. Finally I managed to get it up and running as described here. But after rebooting the system it just doesn't work any more.

Any ideas how to fix that?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Finally, I found a workaround. Dont't know if it is the way to go - but at least it works for me:

Step 1: I created a shell script enableMultitouch.sh as root in the directory /usr/local/bin/ and made it executable. (As described here: http://wiki.ubuntuusers.de/Autostart#Autostart-ueber-Skript.)

Step 2: I pasted the commands as mentioned in the post that described how to enable multi-touch:

#!/bin/sh
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 4
xinput --set-prop --type=int --format=32 "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 8
xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 0

As described here: How to enable Two finger scrolling on Lenovo Thinkpad T400 in Ubuntu 12.04 64 bit

Step 3: Finally I added the script to the startup applications. And now two-finger-scrolling works just fine.

Hope this is somehow helpful...

Cheers!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.