Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.10 on an Asus G75V laptop with nvidia gforce GTX 660M. I first run 12.04 on this machine and was able to install nvidia_current drivers from swat ppa:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current 

This worked in 12.04 and after rebooting the machine my graphics where working properly. After upgrade to 12.10 however, the machine boots into a low resolution desktop which I can not really interact with. I suspect this is due to the driver not being loaded properly. To fix this, I have to switch to ctrl+alt+F1 session and manually load the nvidia_current module and restart the desktop manager:

sudo modprobe nvidia_current
sudo service lightdm restart

Now everything works fine again. However, I would like not to have to do this every time I reboot the machine. I also dont want to hack an script to do this on load. Basically, if things are setup currectly, the nvidia_current driver which is installed should load. How can I make sure nvidia_current driver module loads properly when system starts?

Edit: I tried removing the ppa and installing nvidia-current-update as was suggested in the comments. However, I still face the same problem. The only difference is that now when I restart I come back to desktop with this distorted image:

enter image description here

It appears that nvidia module is not being loaded properly when system boots, even though working drivers are installed.

Again, to work around this issue I can switch to ctrl+alt+F1 session and login. Then I can run this code to get the driver loaded and the desktop back:

sudo modprobe nvidia_current_updates
sudo service lightdm restart

I thought it may be that nvidia_current_updates is somehow being blacklisted somewhere or that nouveau driver is not being blacklisted. So I went into /etc/modprobe.d directory and take a look around. I could not find any evidence of that. Here is the content of nvidia-graphic-drivers.conf which seems relevant:

:/etc/modprobe.d$ cat nvidia-graphics-drivers.conf 
# This file was installed by nvidia-current-updates
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current
blacklist nvidia-173-updates
blacklist nvidia-96-updates
alias nvidia nvidia_current_updates
alias nouveau off
alias lbm-nouveau off
share|improve this question
    
I don't see any packages for Quantal in that PPA. Try removing it with sudo ppa-purge ppa:ubuntu-x-swat/x-updates, and then install nvidia-current-updates from the Drivers Utility. That should set it up properly. –  mikewhatever Oct 26 '12 at 10:32
    
when I try the I get an error that ppa-purge is not a command: sudo: ppa-purge: command not found. Looks like I need to install pps-purge. Will let you know how it goes. –  Aras Oct 26 '12 at 23:21
    
Install it first: sudo apt-get install ppa-purge. –  mikewhatever Oct 26 '12 at 23:56
    
I tried this suggestion, however nvidia_current_updates module behaves the same way and is not loading properly when I reboot the machine. Please see my updated question. –  Aras Oct 27 '12 at 0:54
1  
You could try adding nvidia_current_updates to /etc/modules to ensure autoloading. If that doesn't work, check your Xorg.0.log. –  mikewhatever Oct 27 '12 at 2:06

1 Answer 1

up vote 2 down vote accepted

Since the ppa:ubuntu-x-swat/x-updates PPA currently doesn't have any packages for Quantal, I'd suggest removing it.

sudo apt-get install ppa-purge

sudo ppa-purge ppa:ubuntu-x-swat/x-updates

Then install the recommended or experimental Nvidia driver. You can make sure the module loads by adding it to /etc/modules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.