Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title explains, I have been attempting to install Wine on my laptop which is running 12.10. When I access the command terminal and entered

sudo add-apt-repository ppa:ubuntu-wine/ppa

I was of course met by a password block, when I attempted to enter my password, it flat out wouldn't let me type anything, the only key that got a response from the terminal was "enter" which was met by "incorrect password". To bypass this issue I backed out and used the gksudo command, this new dialogue box seemed to give me access to sudo commands.

I then entered sudo apt-get update and sudo apt-get install wine1.5.

Up until the installation everything went fine, but after entering the final command (still using gksudo) The terminal read "the following packages have unmet dependencies" and proceeded to list a bunch of "recommends"

So my guess is that Wine hasn't been updated to run on 12.10... Is this true, and is there any other way to open .exe's?
Also what was with that funky password mishap?
I'm totally new to Ubuntu so I've just been using support pages and tutorials, sorry if I'm a bit naive in these matters...

share|improve this question
1  
Regarding the "funky password misshap" - in Unix passwords are not echoed to terminal, not even as "****". This is completely normal. Just type your password and press [Enter]. –  Sergey Oct 26 '12 at 4:00

3 Answers 3

I did a ppa-purge on the wine ppa, then I followed this solution How do I resolve unmet dependencies? I just followed the commands of "sudo apt-get clean" "sudo apt-get autoclean" then "sudo apt-get -f install wine1.4". After I did these it installed. Maybe they just updated the packages, idk, but it worked. I just did it also, 7pm eastern time. :D. Take care!

share|improve this answer

All efforts to install wine1.4 or wine 1.5 have been failures - also I thought "answering" would allow me to comment on the original question, unfortunately it did not. This is not the correct answer, but I'll throw this here:

http://www.noobslab.com/2012/08/install-wine-1511-in-ubuntu.html

share|improve this answer
    
You require a certain amount of reputation to comment on other posts. These restrictions - albeit sometimes obstructive - are in place for a reason. –  user98085 Oct 31 '12 at 0:22

To answer the question you asked in the title of your topic:

When you type a password in a Linux shell, it doesn't show anything, on purpose. Just go ahead and type your password and press Enter.

Take a look at the following screenshot from my computer. I typed my password successfully at the su prompt (su is similar to sudo) but saw nothing. My password was still entered correctly and I obtained root.

enter image description here

share|improve this answer
    
Ahh, I see, wow..And as far as my problem with Wine, I think i just needed to restart my computer to let the updates install. This is all starting to make sense to my windows conditioned mind... –  Nocturnus Oct 26 '12 at 4:10
    
@Nocturnus Also, I think the issue with Wine is on Ubuntu's end... others seem to be having similar issues. Wait a few days, and try again. Quantal only recently went final; there is a good chance they're still sorting things out. By the way, I recommend installing the wine package instead of wine1.5. That way, you will always have the latest version of Wine installed. –  thirtythreeforty Oct 26 '12 at 4:17
    
How might one do that? Would you add it to software sources? Or is there an alternative update? --kinda lost at this point, outside the realm of tutorials. --Thanks for all your help thus far, this has really helped! –  Nocturnus Oct 26 '12 at 4:32
    
The wine package is included in the same PPA repository as is wine1.5. The only difference is the wine package will always depend on ("require") the latest version of Wine. So like I said, wait a few days, and give it another shot. I'm having issues installing Wine on Quantal as well. –  thirtythreeforty Oct 26 '12 at 5:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.