Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I removed "./.config" from Home folder, I can not log in to the cinnamon session:

failed to load session "cinnamon"

What do I do?

xsession-error:

Xsession: X session started for tux at Fri Oct 26 06:35:58 IRST 2012
localuser:tux being added to access control list
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service

I am runing Cinnamon on a local machine, no on Virtualbox. but virtualbox is installed for some usage. !?

share|improve this question
    
I already disabled gnome-setting-daemon for problems in Mate and forgotten restore it to primary state, The problem solved with this: sudo mv /etc/xdg/autostart/gnome-settings-daemon.desktop.disabled /etc/xdtostart/gnome-settings-daemon.desktop –  msoa Oct 26 '12 at 7:49
    
If that solved your problem you should add an answer that includes that information. That will help to make it easier to find, especially for newer users. –  Argusvision Nov 3 '12 at 2:17
add comment

1 Answer

I would like to suggest reinstall Cinnamon.log in recue mode pressing shift booting system, choose Recovery mode from grub boot loader options.

First Completely uninstall Cinnamon By

sudo apt-get --Purge cinnamon

Reinstall it by

sudo apt-get install cinnamon
share|improve this answer
    
Didn't work your suggest. –  msoa Oct 26 '12 at 6:15
    
Try to purge Virtualbox also. –  K.K Patel Oct 26 '12 at 6:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.