Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, I was told that I was suppose to install the suggested updates on Update Manager, so I did. Since I usually ignore the Update Manager, it took a long time to install everything. After I restarted my PC, I notice the Internet connection wasn't working. I tried to remove some of the packages I installed earlier but that didn't work. I also tried to upgrade my computer to Ubuntu 12.04 but they said I couldn't because I don't have Internet access. It's been a day and still no connection to the Internet on my PC. Please help me, if you have any solutions.

Thank you.

share|improve this question
    
Could you open a terminal (press Ctrl+Alt+T) and type nm-tool; lspci; and then edit the output into your question? Any more information about the make/model of the wireless card could really help as well. –  Mark Paskal Oct 28 '12 at 1:52
add comment

1 Answer 1

This is one of those, it could be a million different things sorts of problems. Step one is to see how your NIC is configured. Try running:

ifconfig -a

What you will get looks something like this:

eth1      Link encap:Ethernet  HWaddr 00:15:17:12:9a:d6
          inet addr:10.0.0.33  Bcast:0.0.0.0  Mask:255.255.255.0
          inet6 addr: fe80::215:17ff:fe12:9ad6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:262459016 errors:0 dropped:432 overruns:0 frame:0
          TX packets:388373760 errors:158 dropped:0 overruns:0 carrier:158
          collisions:178 txqueuelen:1000
          RX bytes:94742468374 (94.7 GB)  TX bytes:464252544891 (464.2 GB)
          Interrupt:16 Memory:f0800000-f0820000

Look for the inet addr, mask, and particularly that it says, "UP". Post these values and we can work from there.

share|improve this answer
    
Thank you And I'm sorry but how do you run "ifconfig -a" ? –  user100958 Oct 26 '12 at 4:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.