Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 12.10 and one of my media hard drives won't mount. The drive shows up on /dev/sda but doesn't mount. dmesg|tail

[  289.496933] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  292.502310] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  299.540914] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  307.700473] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  307.804819] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  698.017043] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  703.933411] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  704.055936] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  706.293292] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[ 1134.268187] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
share|improve this question
    
I may have found part of the problem.The file system is FAT (32-bit version). It mounted fine in 12.04 but mount in 12.10 64-bit –  Peter Schriver Oct 26 '12 at 0:49
    
My NTFS formatted drive mounts fine. I guess my question should be changed to: Will a FAT (32-bit version) formatted drive that mounted in 12.04 fail to mount properly in 12.10? –  Peter Schriver Oct 26 '12 at 1:06
1  
I think I may have found the problem here bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/… but it doesn't explain the work around well enough for me to fix my problem. Any help would be appreciated –  Peter Schriver Oct 26 '12 at 19:37

1 Answer 1

up vote 2 down vote accepted

Since this bug still exists in Ubuntu 14.04 LTS, I post the following solution that I actually found on the link you posted in your last comment :

try comment=x-gvfs-show instead of comment=gvfs-show (instead of x-gvfs-show)

For people using Disks utility, just uncheck "Show in user interface" in the Mount Options of the partition, and then add comment=x-gvfs-show in the list of options below Symbolic Icon Name :

enter image description here

This should fix the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.