Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was installing a live cd to a usb using dd command and used 'sda' instead of 'sdb' which resulted in all sorts of problems now if I try to install it gives me a

Executing 'grub-install /dev/sda' failed.

This is a fatal error. On everything I try

share|improve this question
    
It sounds like you have overwritten parts of your primary hard drive. Have you tried reformatting the hard drive and start from scratch? I am not putting this as an answer as this will erase all the data and should be tried as the last resort. Hopefully someone else will have a better solution. –  user68186 Oct 25 '12 at 15:42
    
Yes I've tried reformatting many times and reinstalling, to make matters worse it seems like it doesn't format my drive at all when i format and reinstall also it won't format in gparted at all –  Tommybkr Oct 25 '12 at 15:54
2  
How is your hard drive partitioned? If you don not have anything important on the disk, try erasing the partition table and write a new one using "Disk Utility" –  To Do Oct 25 '12 at 16:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.