Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install older version of VLC (1.1.9) because of the sound bug in 2.* which makes it unusable (sound is distorted when the user sets the volume > 100% and then you can't fix it anymore). I've googled about the bug and found out that it's being fixed, but I don't want to install 2.0.4, because it's still a nightly build. The 2.0.3 version (in repos) has this bug.

I tried with Synaptic -> removed vlc 2.0.3 -> right_clicked vlc package -> Properties -> Versions, but there are no older versions. I've found official source (.tar.gz) but I don't want to compile it myself. I can't find any .deb files.

So how do I do this?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You can find the VLC 1.1.9 deb here:

You should consider locking the vlc package to prevent it from getting updated accidentally again.

share|improve this answer
    
Problems - now old dependencies are not satisfied :) Tried installing (first) vlc-nox from the same website and then there are other dependencies not satisfied. I'm afraid to go further so I won't be doing this recursively. What do you think? –  Primož Kralj Oct 25 '12 at 15:55
  • Download here
  • Extract the downloaded .tat.bz2 package
  • To install please read INSTALL file which guide you how to install it.

Configuring

A typical way to configure VLC is:

./configure --prefix=/usr

See ./configure --help for more information.

Building VLC

Once configured, run make to build VLC.

Installing and running VLC

You can install the VLC and its plugins by typing:

make install
share|improve this answer
    
Thank you for the explanation, I am sure many will find it useful. But for the simplicity's sake I'll download .deb from @Edgar's answer. –  Primož Kralj Oct 25 '12 at 15:44
    
@PrimožKralj I understand :) –  Achu Oct 25 '12 at 15:46
    
If you see my third comment from selected answer (@Edgar) - I am having dependency issues now. Will installing it this way (building from source) help or will I have the same problem, if you know? –  Primož Kralj Oct 25 '12 at 15:57
    
@PrimožKralj You don't have to even install VLC after building using that .tat.bz2. If you read it the READ file. You can run it from .vlc directory. Anyway, i didn't tried installing that package. So, i can't tell you that it doesn't have dependency issue. You should try it :) –  Achu Oct 25 '12 at 19:20
    
Thank you for informations, will weight out my options. –  Primož Kralj Oct 25 '12 at 20:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.