Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm getting really low battery life under ubuntu, not even close to windows. I tried powertop, and I saw that my laptop is consuming in idle nearly 20 watts (a bit more).

I tried to install laptop-mode-tools, change "good" into "bad" in powertop, but nothing changes. I see that I have the the HD audio output device which is running at 100% every time. Could this be the problem?

This is a report from powertop.

The battery reports a discharge rate of 22.8 W
The estimated remaining time is 33 minutes

Summary: 381.8 wakeups/second,  0.0 GPU ops/second and 0.0 VFS ops/sec

            Usage       Events/s    Category       Description
          3.2 ms/s     182.7        Timer          tick_sched_timer
        100.0%                      Device         Audio codec hwC0D3: Intel
          7.9 ms/s      25.1        Process        /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background no
          1.9 ms/s      24.2        Interrupt      [6] tasklet(softirq)
          2.9 ms/s      23.2        Process        /usr/lib/chromium-browser/chromium-browser --type=zygote
          8.1 ms/s      20.3        Process        /usr/lib/unity/unity-panel-service
          0.7 ms/s      17.4        Timer          hrtimer_wakeup
          4.2 ms/s      12.6        Process        unity-2d-panel
        604.4 µs/s       9.7        Process        syndaemon -i 2.0 -K -R -t
        149.7 µs/s       9.7        kWork          ieee80211_iface_work
          0.8 ms/s       8.7        Process        metacity
         19.5 ms/s       1.0        Process        powertop
          3.0 ms/s       6.8        Process        //bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
        699.0 µs/s       6.8        Process        /usr/lib/thunderbird/thunderbird
          4.3 ms/s       4.8        Process        gnome-terminal
        658.9 µs/s       2.9        Interrupt      [1] timer(softirq)
         75.1 µs/s       2.9        kWork          iwl_bg_run_time_calib_work
        163.8 µs/s       1.9        Process        /usr/lib/accountsservice/accounts-daemon
         70.6 µs/s       1.9        Process        [ksoftirqd/2]
         25.8 µs/s       1.9        Process        [ksoftirqd/0]
          1.0 ms/s       1.0        Process        /usr/bin/python /usr/sbin/powernapd
        408.2 µs/s       1.0        Process        unity-2d-shell
        189.8 µs/s       1.0        Process        /usr/lib/chromium-browser/chromium-browser
        124.4 µs/s       1.0        Process        /usr/lib/unity-lens-applications/unity-applications-daemon
        113.3 µs/s       1.0        Process        /usr/lib/gnome-settings-daemon/gnome-settings-daemon
        112.0 µs/s       1.0        Process        nautilus -n
        104.9 µs/s       1.0        Process        /usr/lib/gvfs/gvfsd-trash --spawner :1.2 /org/gtk/gvfs/exec_spaw/0
         77.5 µs/s       1.0        Process        /usr/lib/x86_64-linux-gnu/colord/colord
         75.6 µs/s       1.0        Process        /usr/lib/gvfs/gvfs-gdu-volume-monitor
         75.0 µs/s       1.0        Interrupt      [53] i915
         74.9 µs/s       1.0        Process        /usr/lib/gvfs/gvfs-afc-volume-monitor

What should I do to make the battery consumption lower?

share|improve this question
    
What version of ubuntu are you using? if 12.04 or newer: laptop-power-tools have no use anymore since this has been incorporated into the kernel. –  Rinzwind Oct 25 '12 at 14:18
1  
Could be this bug: bugs.launchpad.net/ubuntu/+source/linux/+bug/877560 If so add yourself it the affected ;) –  Rinzwind Oct 25 '12 at 14:21
    
I'm using 12.04, thanks for the info. It could be that bug, but do you think this will justify the nearly 20 watts consumed? I had other notebooks and while idle they were consuming like 7 or 8 watts. –  LucaB Oct 25 '12 at 15:00
4  
What laptop do you have? If you have hybrid graphics, by default both cards are on and they draw a ton of power. –  thirtythreeforty Oct 27 '12 at 21:29
3  
gh403 is right. If you have a hybrid (optimus) graphics card from nvidia, then you need to install the bumblebee drivers, and they will allow your graphics card to sleep. –  Sepero Oct 28 '12 at 5:13
show 5 more comments

1 Answer 1

You should consider installing jupiter

You can select power modes with it, and it's very easy to control. It really saves out battery.

Open terminal and do this.

Add the repository

sudo add-apt-repository ppa:webupd8team/jupiter

Update

sudo apt-get update

Install jupiter

sudo apt-get install jupiter

And to other people reading this and are using an Asus EEPC netbook, install this asswell

sudo apt-get install jupiter-support-eee

Have a nice day :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.