Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get my PCI Wireless Atheros 922 card to work. It is disabled in Unity: both the network utility and the desktop (see screenshot http://www.amisdurailhalanzy.be/Screenshot%20from%202012-10-25%2013:19:54.png)

I tried many different advises on many different forums. Installed 12.10 instead of 12.04, enabled all interfaces... etc. I have read about the aht9 driver... The terminal shows no hw or sw lock for the Atheros card, nevertheless, it is still disabled. Nothing worked so far, the card is still disabled. Any help is much appreciated. Here are more tech details:

myuser@adri1:~$ sudo lshw -C network
  *-network:0 DISABLED    
       description: Wireless interface
       product: AR922X Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 2
       bus info: pci@0000:03:02.0
       logical name: wlan1
       version: 01
       serial: 00:18:e7:cd:68:b1
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.5.0-17-generic     firmware=N/A latency=168 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 memory:d8000000-d800ffff
  *-network:1
       description: Ethernet interface
       product: VT6105/VT6106S [Rhine-III]
       vendor: VIA Technologies, Inc.
       physical id: 6
       bus info: pci@0000:03:06.0
       logical name: eth0
       version: 8b
       serial: 00:11:09:a3:76:4a
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd     100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=via-rhine     driverversion=1.5.0 duplex=half latency=32 link=no maxlatency=8 mingnt=3 multicast=yes port=MII speed=10Mbit/s
       resources: irq:18 ioport:d300(size=256) memory:d8013000-d80130ff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       bus info: usb@1:8.1
       logical name: wlan0
       serial: 00:11:09:51:75:36
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2500usb driverversion=3.5.0-17-generic     firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

myuser@adri1:~$ sudo rfkill list all
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

myuser@adri1:~$ dmesg | grep wlan0
[   15.114235] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

myuser@adri1:~$ dmesg | egrep 'ath|firm'
[   14.617562] ath: EEPROM regdomain: 0x30
[   14.617568] ath: EEPROM indicates we should expect a direct regpair map
[   14.617572] ath: Country alpha2 being used: AM
[   14.617575] ath: Regpair used: 0x30
[   14.637778] ieee80211 phy0: >Selected rate control algorithm 'ath9k_rate_control'
[   14.639410] Registered led device: ath9k-phy0

myuser@adri1:~$ dmesg | grep wlan1
[   15.119922] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

myuser@adri1:~$ lspci -nn | grep 'Atheros'
03:02.0 Network controller [0280]: Atheros Communications Inc. AR922X Wireless Network Adapter [168c:0029] (rev 01)

myuser@adri1:~$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 00:11:09:a3:76:4a  
          inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::211:9ff:fea3:764a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5457 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2548 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3425684 (3.4 MB)  TX bytes:282192 (282.1 KB)
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:590 errors:0 dropped:0 overruns:0 frame:0
          TX packets:590 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:53729 (53.7 KB)  TX bytes:53729 (53.7 KB)

myuser@adri1:~$ sudo iwconfig
wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
lo        no wireless extensions.
eth0      no wireless extensions.
wlan1     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

myuser@adri1:~$ lsmod | grep "ath9k"
ath9k                 116549  0 
mac80211              461161  3 rt2x00usb,rt2x00lib,ath9k
ath9k_common           13783  1 ath9k
ath9k_hw              376155  2 ath9k,ath9k_common
ath                    19187  3 ath9k,ath9k_common,ath9k_hw
cfg80211              175375  4 rt2x00lib,ath9k,mac80211,ath


myuser@adri1:~$ iwlist scan 
wlan0     Failed to read scan data : Network is down
lo        Interface doesn't support scanning.
eth0      Interface doesn't support scanning.
wlan1     Failed to read scan data : Network is down


myuser@adri1:~$  lsb_release -d
Description:    Ubuntu 12.10


myuser@adri1:~$ uname -mr
3.5.0-17-generic i686

![Schizophrenic Ubuntu](http://www.amisdurailhalanzy.be/Screenshot%20from%202012-10-25%2013:19:54.png)

Any help much appreciated... Thanks, Philippe

31-10-2012 ... I have some more updates. When I do the following command it does see my Wifi router... So even if it is still disabled... the card seems to work and see the router (ESSID:"5791BC26-CE9C-11D1-97BF-0000F81E") See below:

sudo iwlist wlan1 scanning
wlan1     Scan completed :
          Cell 01 - Address: 00:19:70:8F:B0:EA
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=51/70  Signal level=-59 dBm  
                    Encryption key:on
                    ESSID:"5791BC26-CE9C-11D1-97BF-0000F81E"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000025dbf2188
                    Extra: Last beacon: 108ms ago
                    IE: Unknown:     002035373931424332362D434539432D313144312D393742462D3030303046383145
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 03010A
                    IE: Unknown: 0706424520010D14
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101030003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010000000000
share|improve this question

3 Answers 3

Here is the work-around that I found...

As Ubuntu'ś UI is clearly at fault, and that the card seems fine ("sudo iwlist wlan1 scanning" finds my router properly), I decided to try to setup the connection the Ubuntu SERVER way = no UI!

Here it goes, in the terminal (CTRL + ALT + T):

sudo apt-get install wpasupplicant

Then I used wpa_passphrase, passing it my SSID and the passphrase

wpa_passphrase <MySSID> <MyPassphrase>

The output of that command was as follows:

network={ 
    ssid="<MySSID>" 
    #psk="<MyPassphrase>" 
    psk=2131b1234fe9ff60abcda4471e773a6ca28a49b6401810abcd2288c2468653a9 
    }  

Then I edited the file /etc/network/interfaces

sudo nano /etc/network/interfaces

And appended this to the file

#The wireless interface
auto wlan1
iface wlan1 inet dhcp
wpa-ssid <MySSID>
wpa-ap-scan 1
wpa-key-mgmt WPA-PSK
wpa-psk <psk obtained by the wpa_passphrase command above>

I rebooted and finally got access to the network, could browse, etc. Please note that the Ubuntu UI is still in the bananas and still shows wireless disabled.

Thanks to ModelR for his post that I used to setup Wifi the Ubuntu Server way:

http://modelr.wordpress.com/2009/06/01/how-to-get-wireless-network-on-ubuntu-server/

If anyone has ideas on how to make the UI work, I am still willing to give that a try...

share|improve this answer

Try this command in the terminal (Ctrl+Alt+T)

rfkill unblock 1

On a similar situation was working fine.

share|improve this answer
    
Also: Please try to include information as to why this works, rather than just saying "Do this." A simple link to the source would be sufficient. –  user98085 Nov 2 '12 at 8:57

Try these commands in the terminal (Ctrl+Alt+T)

sudo modprobe -r iwlagn 
sudo modprobe iwlagn bt_coex_active=0

Type in the first line, hit enter, type in password. Then, type in second line.

Now, see if you can connect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.