Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm doing the following to mount a remote server to a specific path on my server:

sshfs user@remoteserver.com:/backup/folder/ /home/myuser/server-backups/

However when I mount the server the folder permissions change (they become 700), and when I test my rsnapshot.conf file I get the following error:

snapshot_root /home/myuser/server-backups/ - snapshot_root exists \
         but is not readable

What am I doing wrong ? should I mount the remote server with another user ?

share|improve this question
1  
Cross-posted at Ask Ubuntu, Unix Stack Exchange and Server Fault. Please hyperlink your questions when you cross-post so that people can find all answers, and don't waste time posting similar answer independently. –  Gilles Jan 8 '11 at 20:31
add comment

3 Answers 3

up vote 1 down vote accepted

You could try the -o allow_root and -o allow_other options to sshfs.

share|improve this answer
add comment

Set this up on Raspberry Pi (admittedly different distro) but I had the same problem with permission denied. -o allow_other added to the end of the mount call worked a treat.

share|improve this answer
1  
Can you please give details on how to do this? –  RolandiXor Dec 24 '13 at 1:21
add comment

On the backup server make a directory to put the backups in

mkdir /home/patrick/backups

On your vps

Add your user account to the fuse group

sudo usermod -a -G fuse patrick

Edit the /etc/fuse.conf file and uncomment or add the line

user_allow_other

make a mount point for sshfs and connect to it

mkdir /backups

sshfs patrick@backup.tld:/home/patrick/backups /backups -o allow_root

You should now have a /backups directory that you can use rsnapshot with on your vps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.