Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Up to now I had used Intel HD4000 graphics built into the processor, and was using xorg-edgers drivers (mesa and video-intel). Now I have switched to discrete nVidia graphic card and I simply installed nVidia-common from the repositories, I'm seeing nVidia xserver settings and nv-xserver is reporting opengl4.3 and direct rendering:yes and some apps work correctly but some fail to do so; resulting in this command:

LIBGL_DEBUG=verbose glxinfo | grep -i -A 5 -B 5 direct is giving this in terminal:

libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
name of display: :0
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,

I tried to purge and reinstall xserver-xorg and used dpkg-reconfigure xserver-xorg but the same error remains.

Any help or advice would be appreciated.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.