Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Folks I had automatic TRIM working on my laptop running Ubuntu Precise. As in the TRIM guide I added discard to mount options in /etc/fstab, and hdparm --read-sector read 0s immediately after a rm && sync. Using the very same hardware, laptop and SSD, TRIM seems no longer to be automatic after upgrading to Quantal.

I recognise the test in the guide I mentioned above may not necessarily work. SSD erase blocks and all that. But Quantal is at least different. After deleting the file and syncing, its data are still on disk and unerased even after waiting several minutes. fstrim will then 0 the dead file's blocks. Once. Repeat the same test five minutes later, and fstrim does nothing.

I figure this is probably really a kernel issue, but that box is too black for my spelunking torch. I'm prepared to believe that kernel 3.5 knows what I want better than I do, and all is well despite appearances, but it looks for all the world like TRIM isn't quite all there any more. Anybody have the scoop on TRIM in Quantal/kernel 3.5?

share|improve this question
add comment

1 Answer

TRIM support is built into Quantal 3.5 kernels but you need to enable it yourself using the discard mount option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.