Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Alright so I installed Ubuntu last night and I am very new to everything.

Right now I am trying to run a program called JES, (Jython Environment for Students). The instructions tell me to cd to the JES directory I have, so I type

cd /home/Programs/JES

It takes me to the directory I need to be in, so far so good. Then I have to type in:


And I get this returned to me:

bash: ./ Permission denied

I have very little comprehension of what to do in Terminal or anything of the sort. Any help would be appreciated.

I have tried using

sudo -l

to get permissions but it still persists.

share|improve this question

Looks like the file does not have permission to execute it:

chmod +x
share|improve this answer
This worked, thank you! – user1175807 Oct 25 '12 at 4:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.