Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My fresh ubuntu 12.10 install is slow, not something extreme but dragging windows, switching workspaces and things like that are just slow and look horrible. it feels like the fps is dropping in a game. Doing some photoshop work in windows was even a relief! This effect gets worse if I connect my external monitor.

My system is an intel pentium dual core T4500 with 4gb memory and a GeForce 8200M G/integrated/SSE2 graphics chip. Nothing fancy but should be able to run ok. My "experience" in ubuntu is set to standard. (MSI cr500 laptop)

I've installed the nvidia drivers, tried current and experimental and the experimental drivers seem to perform a bit better but overall bad anyway. I set the mode to adaptive in the nvidia-settings tool and it goes to maximum setting directly and doesn't come back.

Using htop I found out that compiz or the X server always use a few percent of my cpu, more than I think it should and the time consumed is 5:18 for compiz, 4:33 for /usr/bin/X and 2:41 for google chrome(about 30 tabs open so not too strange I think.) What can I do to increase the visual performance cause this makes me not want to use ubuntu in public!

share|improve this question
    
What I forgot is that I am using the x64 version of 12.10. –  Steven Stip Oct 24 '12 at 22:47
    
Seems like a lot of people get really bad performance with proprietary drivers in 12.10. Suggestion from other users: Don't upgrade to 12.10 askubuntu.com/questions/207017/… –  LiveWireBT Oct 27 '12 at 13:04

4 Answers 4

On my system (13.04) the problem was with the compiz refresh rate, it is automatically set to 50hz, this is not enough, after changing it to 120hz and disabling the auto detection the interface is smooth. You can change the refresh rate in the compizconfig settings manager. The bad thing is that the refresh rate is always set to 50hz after a restart of the system. Seems to be this bug: Incorrect (low/stuttering) refresh rate with NVIDIA driver

share|improve this answer

I'm inexperienced with nVidia, but you could: 1: Check in CCSM (compiz config settings manager) for the OpenGL, and play around a bit with the configs. (in my case, ati, the sync to vblanc used to produce tearing). CCSM might not be installed by default.

2: You could try the closed or open sourced drivers. This page might help: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Good luck! Cheers.

share|improve this answer
    
I tried this, it didn't really do anything, might have been the difference between 4 and 5 fps –  Steven Stip Oct 25 '12 at 11:42

My experience was the same in 12.04 on my desktop (Nvidia Geforce 230) and laptop (Nvidia Geforce 9300M).

Though there has been much worked on Unity performance in the oneiric cycle I would consider low end Nvidia graphics cards to slow, when you are expecting to run a desktop at 60 fps. By "low end" I mean every model with a 4 or lower as the second number from the left in the model number (X4XX or X4X). This applies for the 200 series and below, but even the 400 series and newer low end cards are mostly rebranded versions of older stripped down designs.

Intel's IGP in Sandy Bridge and Ivy Bridge CPUs on the other side run fine and deliver a 60 fps like performance on the desktop compared to the 24 fps (fluid, but rather sluggish) like performance of Nvidia's low end cards. This may just be a driver issue but it's a long standing one like KMS support for the binary driver. Probably even caused by that.

share|improve this answer
    
it is a nearly 3 year old budget laptop, but the thing that concerns me is that windows runs fine and ubuntu just runs really bad. it's unresponsive when I try to move windows and the unity dash takes about 4 seconds to display a word I type. (opening dash and typing skype takes 4 seconds before it shows what I've typed) –  Steven Stip Oct 25 '12 at 11:40
    
Could you try the xubuntu desktop? It can be installed via the xubuntu-desktop meatpackage. So we could rule out if it is just Unity or something else. –  LiveWireBT Oct 26 '12 at 1:32

I've found that disabling a number of options under the compizconfig settings manager makes it quite a bit faster:

OpenGL>Untick Framebuffer object and Vertex buffer object (and possibly sync to VBlank) and change texture filter to fast.

Ubuntu Unity Plugin>Experimental>Change Dash Blur to No Blur

Animations>Either reduce the time of or change various animations (particularly the minimize ones), or disable them altogether.

This should make Unity much more usable. Xubuntu/XFCE or other environments are also an option.

You could also try using a different driver (e.g. nvidia-experimental-304), or one from the NVIDIA page:

http://www.nvidia.com/object/unix.html

Be sure to run nvidia-xconfig after installing one though, and add nomodeset to grub parameters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.